Support » Plugins and Hacks » Autoptimize » Get this error when i optimize the CSS Code

Viewing 15 replies - 16 through 30 (of 44 total)
  • tokar86a

    (@tokar86a)


    Okay. I hope we fix the problem. I need to improve my pagespeed on https://developers.google.com/speed/pagespeed/

    I get 100 of 100 when i optimize css and js.

    tokar86a

    (@tokar86a)


    I have forgot to tell you that i only seams to get this error when i visit my blog whit Google chrome. I dont get the error whit Firefox. I have not try whit IE becours it dont seems to work on my computer.

    Plugin Author Frank Goossens

    (@futtta)


    That is really weird. As far as I know (not 100% familiar with the entire codebase) there’s nothing browser-specific in Autoptimize (except for some IE-hackery). Would be interesting to know if you have the problem in IE (and Safari) or even Chrome on another computer.

    tokar86a

    (@tokar86a)


    I get the same problem in Safari.

    Plugin Author Frank Goossens

    (@futtta)


    Still very weird … Are you logged in or not in WordPress when the error occurs?

    tokar86a

    (@tokar86a)


    I am not login when the error accurs. But i am that on Firefox. Maybe that is the reason on FF dont have that error.

    Plugin Author Frank Goossens

    (@futtta)


    indeed, when you’re logged in, not optimization is done at all. that’s at least a part of this weird puzzle that falls into place 😉

    tokar86a

    (@tokar86a)


    So what happen now?

    Plugin Author Frank Goossens

    (@futtta)


    Ah, I would have thought you’d have heard my brain grinding frantically on this very subject, but in case you have not heard: I’m … thinking about you 🙂

    I’ll probably create a small plugin over the next few days for your personal pleasure to test some things. Based on the outcome of those tests, I might (or might not, the weird thing is Autoptimize seems to work OK for most users) find ways to improve Autoptimize’s way of doing output buffering.

    Plugin Author Frank Goossens

    (@futtta)


    I’ve been reading up on output buffering errors; can you check (copy/paste) all output buffering options in your php.ini (or .htaccess, if that has such settings)?

    tokar86a

    (@tokar86a)


    I dont know if i have a php.ini file. and i dont have any special things in my .htaccess. Only some tings for my plugin to get installed right.

    Plugin Author Frank Goossens

    (@futtta)


    well, as every php-installation needs a configuration file, it is certain you have a php.ini-file somewhere 🙂

    alternatively the output of phpinfo() might help as well, maybe you can provide me with that (a url to a php with phpinfo)? if you don’t want to post that here, mail me at futtta-at-gmail-dot-com.

    tokar86a

    (@tokar86a)


    So you wont to have info about my php system?

    tokar86a

    (@tokar86a)


    have send you the file now.

    Plugin Author Frank Goossens

    (@futtta)


    ok, could you open up <your site name>/settings/php.ini and in there look for the line that says

    output_buffering=4096

    and change that into
    output_buffering=off

    then restart apache and see if you can use Autoptimize that way?

Viewing 15 replies - 16 through 30 (of 44 total)
  • The topic ‘Get this error when i optimize the CSS Code’ is closed to new replies.