WordPress.org

Forums

Search in Place
[resolved] Get the thumbnail size when using post thumbnail (7 posts)

  1. alexislevrai
    Member
    Posted 2 years ago #

    Hi Codepeople,

    Have got a problem with your plug-in, I select my thumbnail in backoffice, this is the good thumb in search results but the plug-in load the original image and not the thumb size. And sometime this original images are so heavy to load :/

    You see what I want to explain ?

    Thanks you so much for your work !

    Alexis.

    http://wordpress.org/extend/plugins/search-in-place/

  2. codepeople
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Please be sure your post has a Featured Image (formerly known as Post Thumbnail) attached. If a Featured Image is attached to the post, it will be used in search in place results.

  3. alexislevrai
    Member
    Posted 2 years ago #

    Hi,

    Yes my post have a Featured Image and Search in the Place display it that not the problem. But SIP display original size and not thumb size ...

    So search results are very long to load.

  4. codepeople
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    I've checked in different versions of WordPress and the search in place is loading the featured image, associated to the post in all cases. My recommendation is to use the icon version of image as the featured image. If the trouble persists, please contact me through the following link for checking your webpage in details.

    http://wordpress.dwbooster.com/support

  5. alexislevrai
    Member
    Posted 2 years ago #

    That's really strange, I've got the latest wordpress version. I've tried with twenty twelve, eleven, ten template, nothing. With all pluging unactive, same problem :/

    I will contact you via your form.

  6. codepeople
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    I've corrected the issue with the thumbnail. Please, go to the line number 80 of file "/wp-content/plugins/search-in-place/searchinplace.clss.php", and replace:

    $obj->thumbnail = wp_get_attachment_url(get_post_thumbnail_id($result->ID, 'thumbnail'));

    by

    $obj->thumbnail = wp_get_attachment_thumb_url(get_post_thumbnail_id($result->ID, 'thumbnail'));

    The issue was corrected in the online version of files.

  7. alexislevrai
    Member
    Posted 2 years ago #

    Yes nice it work fine but it's not in /wp-content/plugins/search-in-place/searchinplace.clss.php

    it in /wp-content/plugins/search-in-place/php/searchinplace.clss.php

    Thanks !

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Search in Place
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.