Support » Plugin: SiteGround Security » Get the Most of This Plugin

  • This message prompts in every sections/page in the plugin, very annoying and wasting the whole effort done in development, the weekly activity report should be off by default

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Georgi Ganchev

    (@georgiganchev)

    Hello @blueunion

    The message that pops up is part of our data collection. We use the data we collect to improve the work of our plugin.

    You are getting the message on every page as you have not confirmed the form. If you do not agree with the data collection you can decline it and save the settings To do so please click on the Confirm button without selecting the checkbox.

    You can verify the data collection option is not enabled later from the Settings >> SG plugins page where the checkbox will not be selected as well.

    The weekly report is enabled by default as it provides helpful insights into potential traffic increases and threats to the website. If you do not want to receive the weekly reports you can delete the notification email from SG Security > Activity log > Weekly reports > Click the delete button next to your email account.

    I hope this information was helpful to you and wish you good luck with your website.

    Best regards,
    Georgi Ganchev

    Thread Starter blueunion

    (@blueunion)

    Hi Georgi,

    Thanks for your prompt reply.

    I suggest to let the user know by adding a little note in the pop-up message to press the Confirm button without selecting the checkbox to let this annoying message dissappear, or “never show this again” its a common practice.

    Althoug the reporting tool is usefull for some users, I still suggest the option to subscribe to a weekly email to be off by default.

    Thanks

    Regards,
    Mo

    Plugin Support Georgi Ganchev

    (@georgiganchev)

    We appreciate your feedback.

    Our developers will consider your suggestions in future plugin updates.

    Best regards,
    Georgi Ganchev

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this review.