Support » Themes and Templates » Get rid of titles in Twenty Eleven Header w/Child Theme

  • Resolved stephenallen28

    (@stephenallen28)


    Hi,
    I am making a bit of progress using a child theme to modify the Twenty Eleven Theme – though it is still pretty confusing for a newbie!

    I have now gotten rid of all space on top of header and made additional space on sides of the blog.

    But – the problem:
    There seems to be a small circular dot / logo thing that is sticking around on the header image even after making edits. It is centered on the “H2” (header 2) code from the header.php file . . . I believe. That said, I have no idea how to get rid of it – I am hoping there might be a convenient piece of code I could put into the Child Theme that would fix this?

    Here is a photo of my header to show you the problem in top right corner.
    Here is another photo to show you the code that describes it when I click “inspect element.”

    Does anyone have any ideas or suggestions for what I might be able to do in order to edit out this strange circle on the header?

    Any ideas or suggestions would be much appreciated, thanks!!

    Stephen

Viewing 15 replies - 1 through 15 (of 20 total)
  • Should say, making modifications to the Child Theme, not the Twenty Eleven theme…

    Realizing I failed to post link to the original photo of the header – here it is.

    Thanks! Stephen

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Stephenallen28,

    The issue will likely to be resolved through CSS, but would require your website or PasteBin of your HTML and CSS page with the problem.

    Hi Andrew, thanks for quick reply – is there a certain page (header.php?) that should be pasted in? That is fairly easy to do…

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Just the HTML will do; on your web page, right click (If on Windows and where you get the option) and select View Source. The new pop-up window will show your entire HTML for that page. Use that please 🙂

    Great, thanks – here is a link to the source for the home page – perhaps there might be some clues…

    http://pastebin.com/eXhhMWKt

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    In your Child Theme stylesheet, try using the display: none CSS style;

    h2.site-description {
     display: none;
    }

    You can display none anything you want hidden from view.

    Hmm…tried pasting it in to the style sheet but did not seem to have any effect on that mystery bubble in the header. I experimented with brackets and a bit with placing it in different placements, but of course I don’t know anything about code – I just placed the string verbatim right after the initial edits to the header in the style sheet which look like this:

    <hgroup>
    <h1 id=”site-title”><?php bloginfo( ‘name’ ); ?></h1>

    <h2 id=”site-description”><?php bloginfo( ‘description’ ); ?>
    </h2>
    </hgroup>

    Within that group, I tried placing the “none” code before, after, and inside…

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Sorry, I wasn’t clear.
    Paste that none code within your Child Theme’s stylesheet (style.css file).

    Hey Andrew – thanks – sorry, fell asleep last night right after you sent initial code!!

    Okay – yes, I pasted the code into the style.css file in my Child Theme and then saved the file, cleared cache, refreshed browser, did not see any change. The code above is to give reference about where I pasted the code (does that actually matter with the style sheet?)

    At any rate, it seems that the added block of code to the style sheet did not remove the mystery bubble :/

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Sorry, my fault again.

    Try this instead;

    h2#site-description {
     display: none;
    }

    (this time replacing the dot with a hash character)

    Hmm, same result – I followed a series of four or five edits to the style sheet that widened the margins and adjusted header / widgets etc (really good changes actually!) the only problem so far being this mystery bubble. So at this point I think that I will go back through the style sheet to see if I can figure out which of those edits brought up that bubble into the header. Below is the link for the edits that occurred – at this point it feels like finding a needle in a hay stack!! Thanks for your help Andrew – let me know if a brilliant idea emerges, but will not keep drawing you into the goose chase, as I feel I can probably weed out the culprit in my style sheet here! (hopefully, haha!!)
    Stephen
    p.s. – here is link to Voodoo Press for reference – kind of a cool site!

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Just note: This mysterious circle is not-so-mysterious when you add a site description (presupposing text will populate the circle).

    ha! That last comment solved the riddle for me – I was not thinking about the bubble as being a frame / display for text within the header, so when you made that comment it occurred to me to check within the theme / appearance settings. This was the solution:

    Click:
    Appearance Tab > Header;

    Next:
    Uncheck “Show header text with your image.”

    Solved!

    Thanks for help walking through different solutions Andrew, glad to finally get rid of the no-longer–mysterious bubble. Take care.
    Stephen

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Get rid of titles in Twenty Eleven Header w/Child Theme’ is closed to new replies.