WordPress.org

Support

Support » Plugins and Hacks » Media Library Assistant » [Resolved] Get EXIF value to Custom field.

[Resolved] Get EXIF value to Custom field.

  • Djaouws

    @djaouws

    I upload my image with Lightroom and i want to get EXIF value in custom field.
    I map all my data with ALL_EXIF and some data can i save but not all.
    The EXIF array as:
    'THUMBNAIL' => '(ARRAY)', 'ExposureTime' => '1/100', 'FNumber' => '35/10', 'ExposureProgram' => 3, 'ISOSpeedRatings' => 800, 'ExifVersion' => '0230',eg.
    The value i want to save is ExposureTime and ISOSpeedRatings.

    In my Custom field tag ‘LR_ExposureTime’ i tried both THUMBNAIL.ExposureTime and without THUMBNAIL but no data is saved in LR_ExposureTime. Same with ISOSpeedRatings.
    I can save values from another EXIF-array without any problem.

    http://wordpress.org/plugins/media-library-assistant/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author David Lingren

    @dglingren

    You should be able to map both of these fields on the IPTC/EXIF tab as “ExposureTime” and “ISOSpeedRatings”. The THUMBNAIL array is a completely separate field and your two desired fields are not part of it.

    If you can post a link to one or more of the images you’d like to process I can examine them and give you a more specific answer. If you can’t post a link, you can contact me through our web site and I will send you an e-mail address to which you can send them. Write me from the “Contact Us” page at our web site:

    Fair Trade Judaica/Contact Us

    Thanks for your interest and for your patience.

    Djaouws

    @djaouws

    Hi

    Here is a print screen of my mapping:
    http://tinyurl.com/qe4zfg7 The field LR_camera and LR_fstop works but not the other two.

    Her’s a link to my testportfolio where i have 2 galleries.
    http://www.jannearvid.se/test-iptcexif/

    In the gallery in the top my template the markup look like this:
    Info: [+custom:LR_exposetime +]s, [+custom:LR_fstop+], ISO [+custom:LR_iso +].

    And in bottom gallery.
    ALL IPTC:
    [+exif:ALL_IPTC+]
    ALL EXIF:
    [+exif:ALL_EXIF+]

    Plugin Author David Lingren

    @dglingren

    Thank you for this update and for taking the time to document your issue and post links to the screens and galleries. Your rules are fine and your images contain the information you want.

    Based on the information you gave me I have found a defect in the current MLA version. On the Settings/Media Library Assistant “Custom Fields” and “IPTC/EXIF” tabs, the “Add Rule/Add Field and Map All Attachments” buttons do not map the values from the attachments into the custom fields. Once the rule is in place you can map values without further problems.

    I will fix this problem in my next release. Until then, I believe you can use the IPTC/EXIF tab “Map All Attachments” button for a specific rule or the “Map All Attachments, Custom Fields Now” button to apply all of your rules at once. Please give this a try and let me know if it works for you.

    I regret any inconvenience this issue has caused you. I will leave this topic unresolved until I release the next version, and I will update it when the next version goes out.

    If the interim workaround I gave you does not work, let me know. Thanks again for bringing this defect to my attention.

    Djaouws

    @djaouws

    Thank your for the answer.
    If i update rule and click both “Map All Attachments” button or the “Map All Attachments, Custom Fields Now” button nothing is updating.

    I’ve wait for the next realese.

    Plugin Author David Lingren

    @dglingren

    I regret that you are still having trouble with this feature. The only defect I’ve fixed is related to adding a rule and mapping attachments in the same step.

    I have just looked more carefully at the markup you posted:

    In the gallery in the top my template the markup look like this:
    Info: [+custom:LR_exposetime +]s, [+custom:LR_fstop+], ISO [+custom:LR_iso +].

    It looks like you have a space after LR_exposetime and before the closing +], and also after your LR_iso. If that’s true, the data will not be displayed. Please check your shortcode and correct it if necessary.

    You can see if the mapping works by editing one of your attachments and looking for the custom field data it contains. Go to the “Edit Media” screen for an image and scroll down through the Custom Fields information. See if your exposure and iso data is present.

    I hope removing the spaces from your shortcode parameters will solve your problem; let me know if that works. Either way, you have helped me find and fix a bug, which is great. Thanks again.

    Djaouws

    @djaouws

    Yeeaa… 🙂
    The space was the answer!

    Had not thought about this but it may be possible to read the documentation somewhere.

    Thanks for a excellent plugin.

    Jonas Lundman

    @jonas-lundman

    Is there a separate forum for Media Library Assistant only and EXIF mapping, photo-tech mapping, where we all can share our working solutions for diffrent meta-data, equipment, import, and trix … ?

    I mean, as a collected faq? I spend hours to just get my Google Picasa descriptions to get mapped as Worpress captions on upload …

    esmi

    @esmi

    Forum Moderator

    @jonas Lundman: If you require assistance then, as per the Forum Welcome, please post your own topic. This topic has been resolved.

    Plugin Author David Lingren

    @dglingren

    @jonas Lundman: I would like to create a separate forum for this kind of dialog/exchange, but for now it’s all I can do to keep up with support requests and continue development.

    It’s on my wish list, though!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Get EXIF value to Custom field.’ is closed to new replies.
Skip to toolbar