Support » Plugin: Gravity Forms Infusionsoft Feed » Get error when submitting form

  • Resolved lahiggins

    (@lahiggins)


    Users get this error message when filling out the form:
    Warning: count(): Parameter must be an array or an object that implements Countable in /home/pulmonx6/public_html/wp-content/plugins/systasis-gf-infusionsoft-feed/class-gravityforms-infusionsoft-integrator.php on line 1631

    Please advise.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Systasis Computer Systems

    (@systasiscomputersystems)

    Hi,
    Thanks for reporting!
    You can fix the error by upgrading the Novak SDK. Log into WordPress as an admin. There should be a message on the plugins page to the effect that the plugin needs upgrading. I’m pretty sure they’ve fixed the code in the past year or so.

    The error’s only a warning and will not affect transmitting the form data to Infusionsoft.

    Are visitors to your page seeing the error? If so, check the setting of WP_DEBUG in wp-config.php. It’s been a while since I encountered this issue. I don’t remember where the message surfaced

    Thread Starter lahiggins

    (@lahiggins)

    Thank you for your reply.

    However, I’m not seeing a message on the plugins page. I am running the most recent version of Gravity Forms and this plugin.

    Yes, visitors are seeing this message on the front end of the site and I need this resolved ASAP.

    Can you give me instructions on your last point: “If so, check the setting of WP_DEBUG in wp-config.php.”

    I’m not sure what you mean by that.

    Plugin Author Systasis Computer Systems

    (@systasiscomputersystems)

    Hi,
    Please post the versions of the Gravity Forms feed and the Novak SDK. A screen shot is fine.
    You’ll need to use a text editor to edit the file wp-config.php If you don’t know what that means, please contact the person responsible for installing WordPress. Otherwise, search for “WP_DEBUG” and set its value false. It doesn’t look like that’s the problem, though. Have you just installed this plugin? Perhaps your server software was upgraded in the past few days?

    UPDATED TO ADD:
    Your error looks similar to the issue opened in this thread:
    https://wordpress.org/support/topic/error-warning-count-not-resolved/

    You’ll need technical support to resolve this. I think your site has more than version of XMLRPC.INC installed. As noted in the linked thread, you’ll want to find the offending version and replace it with the supported version from Novak’s SDK.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Get error when submitting form’ is closed to new replies.