Support » Plugin: WooCommerce Blocks » Get error selecting individual products

  • Resolved adrianwackernah

    (@adrianwackernah)


    Upgraded to WordPress 5.0 and Woo Product Blocks 1.2.0 and tried using select individual products. In 5 tests I got 4 times a error that preview can not be loaded and after than product blocks in unusable. Message:

    “This block encountered a error and preview is not possible”

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Contributor James Koster

    (@jameskoster)

    Hey,

    I was unable to replicate this issue on my local install, could you provide a little more information?

    Do you have any other plugins active?

    What kind of products are you trying to display (simple, variable, etc)?

    James
    Designer @ Automattic

    Hello James,
    I tried this on same server but two different sites. Well I have few extensions installed beside woocommerce like subscriptions, product bundles and few others. I did not check with extensions disabled beside woocommerce because at all I need them all.

    I tried simple, variable, subcriptions and bundled products too.

    I gave it a try again few minutes ago and wrote few letters from a simple product title into search box and got the error shortly before I finished. The error is always the same. After error whole block is unusable except I may delete it.

    Beside staging Server runs PHP 7.2.11, has 256 MB of RAM for WP and this plugins activated:

    Code Snippets von Shea Bunge – 2.12.1
    The Events Calendar von Modern Tribe, Inc. – 4.7.1
    WooCommerce Cash On Pickup von Marian Kadanka – 1.5
    WooCommerce Blocks von Automattic – 1.2.0
    WooCommerce Germanized von Vendidero – 2.2.4
    WooCommerce Product Add-ons von WooCommerce – 3.0.4
    WooCommerce Product Bundles – Min/Max Items von SomewhereWarm – 1.3.4
    WooCommerce Product Bundles von SomewhereWarm – 5.9.0
    WooCommerce Subscriptions von Prospress Inc. – 2.4.5
    WooCommerce von Automattic – 3.5.2

    Plugin Contributor James Koster

    (@jameskoster)

    Hey,

    So the error occurs only when you search? That’s interesting. How many products do you have at your store?

    May I ask that you temporarily disable your other extensions so that we can rule out a potential conflict? Hopefully you have a staging area to do this. I wonder if the different product types are having an impact here.

    James
    Designer @ Automattic

    Hey James, on live site I have a bit over thousand products, on staging site there are only a handful of 20 to 30 products.

    Well, I will give it a try disabling all other plugins on staging site and report later.

    OK, I tried and no change. Only WooCommerce 3.5.2 and Product Blocks 1.2.0 are active. I went over to a page and added a product block, selected individual product, typed in one letter and got the error. My theme is Storefront 2.4.1.

    Any idea?

    Beside both sites are secured by https!

    Plugin Contributor James Koster

    (@jameskoster)

    Do you products have images? I noticed this issue: https://github.com/woocommerce/woocommerce-gutenberg-products-block/issues/226

    Hi James, I check few minutes ago. I had a product named Composite with an image. At product block I typed in “Com” and got the error. I checked with another product name with image and it needed only one letter to get the error.

    Beside: I am on macOS too but instead I use Safari. But my macOS is Mojave 10.14.2

    Hi here,

    I am getting the same issue, it fails for some products but works for others. It seems it’s something to do with the names? Names of products that failed:

    Star Wars: Legion 2019 Ticket
    Warmachine/Hordes 2019 Ticket

    Any other products without special characters in the names work fine.

    Although the funny thing is, if I remove the special characters from the names, it doesn’t seem to help. Going to see about changing some other things and see if I can really narrow down the problem.

    By the way console error:
    TypeError: Cannot read property ‘src’ of undefined

    Plugin Support Mike W

    (@nixiack8)

    Hi @veskit, @adrianwackernah,

    I apologize for the wait on a response. We have updated the plugin a few times since the last reply, are you still experiencing the issue? Please let us know!

    For me it is solved. Thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Get error selecting individual products’ is closed to new replies.