Support » Plugin: Fast Velocity Minify » Get an Error Message since the Last Update in Google Pagespeed Check

  • Resolved marcoeitelmann

    (@marcoeitelmann)


    Hello,

    first, sorry for my midrage english skills 🙂

    I hope you can help me, since the last 1-2 updates i get an error with the following content in Google Pagespeed Tools:
    “””””””””””””””””””
    Warnungen: Lighthouse was unable to automatically check the font-display value for the following URL: https://www.passives-einkommen-verdienen.de/wp-content/themes/mh-magazine/mh-magazine/fonts/fontawesome-webfont.woff2.
    “””””””””””””””””””

    It is on alle my sites togrther (5 Websites). If i deactive the Plugin, the error disapears. I i install the plugin version (3 version fewer) it also disapears.

    Your Plugin is great, i still prefer it as one of the best plugins für css and js minification. I hope you can help me with this error.

    Greeting from Germany
    Marco Eitelmann
    https://www.passives-einkommen-verdienen.de

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Raul P.

    (@alignak)

    Hi,

    Looking at your page, the reference to that font appears on the body, because you are inlining all CSS. http://prntscr.com/or8tpm

    What that error is saying is two things.

    a) you are missing a css font-display property on our css file.
    Ask the theme support to add the font-display: block; property to the fontawesome font (screenshot above), or edit it yourself.
    b) You are inlining fontawesome, but google cannot detect any icon in use… therefore, it sees the font, but cannot guess how the font should be rendered.
    https://developers.google.com/web/updates/2016/02/font-display

    You should not inline all css on fvm settings, unless that’s the only one that works.
    And even if that is true, you can probably use the ignore list.
    https://wordpress.org/plugins/fast-velocity-minify/faq/

    Load your fontawesome async on the fvm settings, instead of inlining it.
    Icons are precisely the the of large css code which can be loaded async.

    I’m not sure why it works with an older version, because there haven’t been that many changes on the updates.

    As explained on the plugin description, you may need to hire a developer to help you with the speed optimization if your site score is still very low, or if you have a complex site.

    Sorry that I cannot help further.

    Hello Raul,

    oh yes, this helped me alot! Thank you so much! I just changed to the point:
    “Async Font Awesome CSS file [ Will use preload with LoadCSS polyfill ]”
    And deselected:
    “Merge or Inline Font Awesome CSS [ Depends on if you have the Inline CSS option enabled or not ]”

    It works perfect! And i also get a mobile Pagespeed benefit since then on Google between 3-5 Points and higher for each website project!

    Absolutly great, thank you so much!

    Greeting from Germany
    Marco Eitelmann

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.