Support » Plugin: All in One SEO Pack » Get a 504.shtml redirect to a 404 page after activating AIOSEO

  • Resolved threedogmoon

    (@threedogmoon)


    Hello folks. Upon troubleshooting all my plugins, I find AIOSEO to be the culprit for the following problem:

    Upon activating AIOSEO from the plugins page, I get locked out of every admin page on my site. The site works fine for the end user – I just can’t get back into the admin panel. Instead, I get a 504.shtml redirect to a 404 page that reads the standard: “Oops…, I cannot find the page you are looking for, sorry… ( Error 404 ) Let me help you find it:”

    The page url looks like this: https://droneclick.com/504.shtml/

    Does anyone know how/why AIOSEO could be causing this. One thing to note is that the site contains 21,000 posts. I have the sitemap breaking things down to 500 entries a page, but I do not think this is the issue.

    Any help would be greatly appreciated.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    Please try the troubleshooting steps with AIOSEOP remaining active to locate a possible plugin/theme conflict. https://semperplugins.com/documentation/how-to-troubleshoot-issues-with-all-in-one-seo-pack/
    Make sure to remove any customizations to your wp-config.php file, .htaccess, etc.

    Also, some background information would help.
    For instance, did you recently update/install AIOSEOP, another plugin, your theme, and/or WordPress, and this behavior started then?

    Thanks Michael. Started after the last AIOSEO update. A theme update was also done. No wp core updates were done. My .htaccess file is and has been highly modified, should I just disable it all together or install a “stock” .htaccess?

    I appreciate your time.

    Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    My .htaccess file is and has been highly modified, should I just disable it all together or install a “stock” .htaccess?

    As I said, remove any customizations to your .htaccess file, and any other customizations you may have.

    A theme update was also done.

    Try restoring the old version of the theme.

    It is not the .htaccess file. Swapped that out, no improvement.

    As for the theme, I cannot easily go back 1 version as there is a theme dependent plugin that updates along with the theme. It is part of the theme’s core functionality.

    The issue does, however, completely resolve if AIOSEO is disabled.

    Since I am not a server expert, I reached out to my management company (Liquidweb) and they confirmed that the issue is being caused by AIOSEO, therefore it is not a server-side problem. It could, however, still be a compatibility issue with my theme (Udesign). I have been using AIOSEO and Udesign together for some time without issue. Will see what the next update brings and report back here. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Get a 504.shtml redirect to a 404 page after activating AIOSEO’ is closed to new replies.