Support » Plugin: Events Manager » German translation Error after Update

Viewing 7 replies - 1 through 7 (of 7 total)
  • agelonwl

    (@angelonwl)

    Hi,

    you can changed that using Settings > Bookings > Customize Feedback Messages

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    If you installed EM with with the blog language in English, the defaults are installed in English.

    Also, it may be an outdated po file (i.e. lines of where translations are have changed, translations aren’t being found properly).

    ito

    (@consolem)

    @agelonwl. that was not my question.

    @Marucs po file (dbem-de_de.po) was adapted…

    \#@ dbem
    #: em-install.php:542
    msgid “You are currently attending this event.”
    msgstr “Sie haben bereits eine Buchung für diese Veranstaltung getätigt.”



    #@ dbem
    #: admin/em-options.php:1311
    msgid “Already attending”
    msgstr “Sie haben bereits eine Buchung für diese Veranstaltung getätigt.”\

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Try updating the German po file from the POT file as instructed here:
    http://wp-events-plugin.com/documentation/translating/

    I’ve only recently discovered that anything showing up as ‘fuzzy’ isn’t translated, you have to go through each record and mark it ‘unfuzzy’. Unfortunately the German translation has a lot of these as it hasn’t been updated in a while.

    ito

    (@consolem)

    🙁 It doesn’t work for me too.

    in ‘bookingform.php’ is the following code:

    <?php //echo get_option('dbem_bookings_form_msg_attending'); ?>
    <a href="<?php echo em_get_my_bookings_url(); ?>"><?php echo get_option('dbem_bookings_form_msg_bookings_link'); ?></a>

    In ’em-options.php’ is the following line:

    em_options_input_text ( __( 'Already attending', 'dbem' ), 'dbem_bookings_form_msg_attending', __( 'If already attending and double bookings are disabled, this message will be displayed, followed by a link to the users booking page.', 'dbem' ) );

    These two items are correctly displayed in the po file.

    Puhhhh…

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    That’s because once you install EM, that msg is saved to the database, the translation is only used then, afterwards it’s taken from the DB, so if you change that in your options page (as per angelonwl’s original suggestion), it should show the right text.

    ito

    (@consolem)

    Thanks, it works fine…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘German translation Error after Update’ is closed to new replies.