Support » Fixing WordPress » geolocation isn’t working

  • setup the states that are allowed and it won’t show shipping postage unless you fill in the checkout page. don’t need them to fill out checkout form is the customer is using the paypal button. as I get the address from paypal

Viewing 2 replies - 1 through 2 (of 2 total)
  • I do not fully understand your question. In fact, you did not specify where you have problems. That might be useful.

    I really need to use Geolocation; What should I do?

    If you would like to use the HTML5 Geolocation API, or if your site already uses the Geolocation API, please migrate the pages making Geolocation API calls to HTTPS, ensuring that they’re used in a secure context.

    There are a number of fallback options available to get a user’s location that are not affected by this change, such as Google Maps Geolocation API, GeoIP (as an example, there are other geo based solutions), and a user-entered zip code. However, we strongly recommend that the best path to ensure ongoing access to geolocation is to move to HTTPS.

    Source:https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only

    Thread Starter cacti1971

    (@cacti1971)

    What causes Shipping zones not to work in woo commerce.
    for example.
    Shipping zone.
    shipping name. Australia
    shipping zone. QLD, NSW, VIC.
    Shipping methods. I have added shipping methods. flat rate, free shipping, and express shipping.

    In general under,
    Default customer location I have it set as Geolocate (with the page caching support.)
    try the other setting as well to get it to work.

    in shipping options, I have the calculate turn off.
    if I have debug mode turn on these are the messages I get.
    1.Customer matched zone location not covered by your other zone.
    2. You don’t ship to Australia

    These messages are coming up even you are from the states I have chosen that I ship too.
    what am I doing wrong?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘geolocation isn’t working’ is closed to new replies.