Support » Plugin: WooCommerce » Geolocate not working

  • Resolved mrretail

    (@mrretail)


    The shipping zone I have set has specific states only, as there are some states we cannot sell cactus to. Default customer location is set to geolocate. Has been working fine but suddenly, in the last few days, my customers are getting “Enter your address to view shipping options” on the cart, even though the only options available are flat rate shipping and free shipping.

    When I set up a test zone, without any set states, the cart shows shipping costs, as expected (and as it used to), so the issue appears to be to do with geolocation, i.e. Woocommerce is not identifying that the buyer is in the correct state, so it asks for the address as to know whether to show the shipping rates or not.

    Everything works when I am signed in as Admin, as it remembers my address details from previous entries. Different desktop browsers make no difference.

    I have tried deactivating all plugins other than Woocommerce but no change.

    Any suggestions?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Zach W

    (@dynamiczach)

    Automattic Happiness Engineer

    Howdy!

    Could you please check your site’s System Status? You can find it via WooCommerce > Status. There may be an issue with Geolocation for your site, and you can check that in the MaxMind GeoIP database: section.

    Also, make sure you don’t have caching setup (plugin or server-side) for the cart/checkout/my account pages. If you do, remove that and test.

    Hi @dynamiczach
    The status for Maxmind is green. We don’t have caching setup, although Jetpack may be doing some kind of caching, for the lazy loading of images. I tried changing Default customer location to “Geolocate with page caching support” but it didn’t seem to make any difference either; or does that take time to work?

    Plugin Support Zach W

    (@dynamiczach)

    Automattic Happiness Engineer

    Thanks for that information!

    I’d recommend setting up a test/staging site and then trying the information here to test for theme/plugin conflicts:

    https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    I’d also recommend contacting your hosting provider to have them confirm that there is no server-side caching on the cart/checkout/my account pages, and that the MaxMind GeoIP database is functioning properly.

    Plugin Support Luminus

    (@luminus)

    Automattic Happiness Engineer

    Hi @mrretail,

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Geolocate not working’ is closed to new replies.