WordPress.org

Ready to get started?Download WordPress

Forums

WP Statistics
[resolved] GeoLite2 doesn't work for me (8 posts)

  1. muinom
    Member
    Posted 7 months ago #

    Hi,

    Nothing appears on the map and for the countries it says 'unknown'. There was an error message when the plugin downloaded informing me of this. I don't know anything about coding.

    My boyfriend downloaded it for his website on the same day and it works fine for him.

    Can you help me please ?

    https://wordpress.org/plugins/wp-statistics/

  2. Greg Ross
    Member
    Plugin Author

    Posted 7 months ago #

    You need to check a few things:

    - Have you enabled GeoIP in Statistics->Settings->GeoIP?
    - On the Statistics->Optmization->Updates page what is the file size of the GeoIP database?
    - Are you seeing IP addresses in the hits log, are they in the 10.0.0.0/172.16.0.0/192.168.0.0 ranges?

  3. muinom
    Member
    Posted 7 months ago #

    Yes I did.

    It says the file does not exist ....so size is n/a ?

    I'm seeing IP addresses in the "Last Visitors" log and they look like this 93.27.20.210

  4. muinom
    Member
    Posted 7 months ago #

    Yes I did.

    It says the file doesn't exist....?

    I'm seeing IP addresses in the "Last Visitors" log and they look like this 93.27.20.210.

    I'm based in France, don't know if this makes a difference, it shouldn't...

  5. Greg Ross
    Member
    Plugin Author

    Posted 7 months ago #

    The GeoIP database hasn't been downloaded yet, go to Statistics->Settings->GeoIP and check the "Update GeoIP Info" box, then save the settings.

    Then check the database size again.

  6. muinom
    Member
    Posted 7 months ago #

    I did what you said but it doesn't work. I get this message

    Error downloading GeoIP database from: http://geolite.maxmind.com/download/geoip/database/GeoLite2-Country.mmdb.gz - Forbidden

    I don't understand why there is an error.....

    Can I create an admin user for you, it'll be quicker....

  7. Greg Ross
    Member
    Plugin Author

    Posted 7 months ago #

    No need for an admin user, the error means that maxmind has blocked your host from downloading the database.

    You can manually do it with the following steps:

    - On another system (any PC will do) download the maxmind database from http://geolite.maxmind.com/download/geoip/database/GeoLite2-Country.mmdb.gz
    - Decompress the database
    - Connect to your web host and create a "wp-statistics" directory in your wordpress uploads folder (usually it is located in wp-content, so you would create a directory "wp-content/uploads/wp-statistics").
    - Upload the GeoLite-Country.mmdb file to the folder you just created.

    You can also ask maxmind to unblock your host.

  8. Greg Ross
    Member
    Plugin Author

    Posted 6 months ago #

    Closing due to inactivity.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags