Support » Plugin: Slimstat Analytics » GeoLite and Browscap cannot be installed and other

  • Resolved Ursula S.

    (@ursula-s)


    Hi,

    I installed your plugin today and I think I like it very much – thank you for your great work!

    I only have one problem: I cannot install GeoLite and Broscap; if I try i get

    There was an error downloading the MaxMind Geolite DB: Service Unavailable

    and the same for Browscap. What can I do? I have php 5.6.

    Thank you in advance for your help and sorry for my bad English!

    Edit: Now, half an hour later, the error message is

    There was an error downloading the MaxMind Geolite DB: cURL error 7:

    __________________

    Again an edit, sorry for that. I wanted the file extensions ‘jpg’ to be treated as download; I would like to see which pictures people click. If I add it to the file extensions list my lightbox does not work any more. Here I need help too please.

    • This topic was modified 2 years, 8 months ago by Ursula S..
    • This topic was modified 2 years, 8 months ago by Ursula S..
Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    Ursula,

    it sounds like your hosting provider is blocking connections to both the MaxMind and Browscap repositories, which results in the error message you see. Please contact your provider to see if they have any input on this. Mention that you are getting an error message related to cURL.

    As for tracking JPGs, you need to let the tracker know that you have some kind of lightbox library. Please take a look at our knowledge base to learn how to solve this problem:

    https://slimstat.freshdesk.com/support/solutions/articles/5000528534-i-noticed-a-conflict-with-your-lightbox-library-here-what-can-i-do-

    Best,
    Jason

    Hi Jason,

    thank you for your quick answer. My hoster supports cURL; I took a look in the php.info. Before I installed your statistic I used Piwik and there I could download the GeoLite-File without any problem. Is there perhaps a way to add the file by hand via ftp?

    Because of the jpg-tracking: The problem is that I have all jpgs opening in a lightbox so that the solution of your knowledge base does no work for me – if I understood it right. But this is no great problem and no reason to not use your plugin 🙂

    I have a wp installation with browscap-db.php present in /wp-content/plugins/wp-slimstat/browscap.
    But the dashboard still says in several places, that I should install it.
    However, trying to install it by clicking on the Install button, results in an error, stating that folder permissions might be wrong. All other plugins can read/write to their respective folders, and I’ve also even tried uploading the browscap-db.php manually to /wp-content/uploads/wp-slimstat/ to no avail. Where should this browscap-db.php file reside ?
    I’m an advanced user, I can easily put it whereever it needs to reside.

    Plugin Author Jason Crouse

    (@coolmann)

    @computershowtopro please start your own thread per forum policy and etiquette.

    @ursula-s, you can specify the file extension in the settings (jpg) to tell Slimstat to not attach the callback function to any link whose HREF contains jpg. That should work, no?

    You can contact us at http://support.wp-slimstat.com and I will send you a copy of the zip file with the instructions on how to install it on your server.

    Best,
    Jason

    Ok, I’ll do that

    Hi Jason,

    thank you so much for your patience and your explanation. English and me isn’t a real lovestory so I often have problems understanding English texts.

    But now I think I got it. I activated ‘Track internal clicks’ and wrote ‘jpg’ at ‘No callback’. It looks like that:

    But I do not see clicks on my jpgs? I thought I can see the clicks at the Access Log?! Perhaps this is wrong? The images are as wordpress galleries in my posts; is this a problem?

    I’m very sorry for all my questions. Because of the GeoLite DB I will contact you under the link you posted.

    Thank you again!

    • This reply was modified 2 years, 8 months ago by Ursula S..
    Plugin Author Jason Crouse

    (@coolmann)

    Ursula, could you please post (or send via our support platform) the URL of the page where the issue is occurring? I’d like to check that everything is set the way it should be.

    Best,
    Jason

    Hi Jason,

    it’s https://www.ditzumblog.de. There is a lot of sheeps… 🙂

    Thank you so much! If you need an admin account let me know.

    • This reply was modified 2 years, 8 months ago by Ursula S..
    Plugin Author Jason Crouse

    (@coolmann)

    Those sheep are so cute! 🙂 Regarding the issue at hand: please “jpg” to the list of extensions to be identified as a DOWNLOAD, under Slimstat > Settings > Tracker > Advanced > Extensions to track. This will instruct the algorithm to treat those lightbox clicks as download, and they will appear in your access log and other reports as regular links followed by your visitors.

    Also, we are improving this feature in Slimstat 4.6.2, so you will definitely see some improvements, once it’s released.

    Let me know if this makes any sense.

    Best,
    Jason

    Jason, you are my hero! It works perfectly! I put jpg als download, and let ‘Track internal clicks’ on – I’m happy 🙂 And I’m looking forward to the update.

    Thank you so much for great your help! I’ll mark this thread as solved and hope, it’s ok.

    Plugin Author Jason Crouse

    (@coolmann)

    Hi Ursula,

    Please consider writing a review for Slimstat as a token of appreciation for the support you received. It would be a nice way to say thank you and to let people know how much you value this plugin:

    https://wordpress.org/support/plugin/wp-slimstat/reviews/#new-post

    Best,
    Jason

    I think I wrote a review 3 1/2 years ago – I can’t remember I did?! I only could edit this old review; at that time I also gave five stars. The review is here.

    Plugin Author Jason Crouse

    (@coolmann)

    Oh wow, thank you for being such a loyal user! 🙂

    Hi Jason,

    sorry, it’s me again. Unfortunately after the upate the tracking of clicks on jpgs without breaking the lightbox does not work anymore. I tested different configurations with the ‘No callback’ and the ‘Tread as Download’-Settings:

    1. No Callback: jpg not added, Tread as Download: jpg not added -> Lightbox ok, jpgs are not tracked

    2. No CallbacK: jpg not added, Tread as Download: jpg added -> Lightbox broken, jpgs are not tracked

    3. No Callback: jpg added, Tread as Download: jpg added -> Lightbox broken, jpgs are tracked

    4. No Callback: jpg added, Tread as Download: jpg not added -> Lightbox broken, jpgs are tracked

    Do I think the wrong way? I would be very thankfull for your help again!

    Plugin Author Jason Crouse

    (@coolmann)

    Hi Ursula,

    I just visited your website, what setting do you have right now? The issue was probably caused by the fact that our Content Delivery Network server was still serving the old version of our Javascript tracker. I flushed the server cache, and it should work now. Can you please try again with option 3 (which is what you want).

    Thank you,
    Jason

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘GeoLite and Browscap cannot be installed and other’ is closed to new replies.