Support » Plugin: Cookie Consent » GeoIP detect doesn’t work?

  • Resolved dragonwolf5589

    (@dragonwolf5589)



    If i test geoip with the plugin it shows correctly and works.

    But if I use a vpn or proxy and visit my website from usa, I still get the eu cookie banner. How do I get it to work so only people in the EU get the banner and I don’t have to inconvenience worldwide users with this stupid eu cookie law – other then this issue the rest works fine.

Viewing 8 replies - 1 through 8 (of 8 total)
  • update: your demo site does not show any eu banner when on the vpn. but it does show as soon i disconnect from the usa vpn, so i must be doing something wrong as it wont work for me

    Plugin Author Catapult_Themes

    (@catapult_themes)

    Make sure that in Settings > Cookie Consent > General tab, you have North America selected in the Exclude Zones field.

    I’m not certain how the GeoIP plugin works with a VPN or proxy. You might need to check that with the plugin author: https://wordpress.org/support/plugin/geoip-detect

    Hi, I have selected everything except europe. The odd thing is on the demo site it works perfectly with a vpn/proxy. I never see the message unless it turn it off or use any other europe proxy. if i use one out of europe I do not see the banner as expected. But it shows up all the time on my site even though everything but europe is selected

    Plugin Author Catapult_Themes

    (@catapult_themes)

    Can you post a link to your site?

    Hi, it is https://nemdoreviews.co.uk,

    (Today seem to be getting a few Error 520 from cloudflare that im trying to work out – so you may need to refresh the page a couple times)

    I also use cloudflare cdn to minify and speed up the site and w3 total cache etc, could this causing any issues? I did clear all the caches yesterday morning though.

    Plugin Author Catapult_Themes

    (@catapult_themes)

    I can’t see any problems with it. It’s possibly related to your VPN – I’m in Europe and it’s displaying correctly for me. I can also see that the correct classes are being added to the body so possibly the GeoIP plugin can’t locate the IP address you’re using.

    Ok, I’ll ask at the geoIP plugin to see if they can work it out. Just seems odd if i access any other sites with the plugin via the vpn the box doesnt appear. Thanks for the reply.

    Hi, I have the same problem with your plugin and to discard the VPN as reason I just made it the other way round, selected Europe as excluded zone expecting that will result in cookie consent banner won’t show up if I’m accessing from an European locations, Spain.
    But it does still appear every time you clean your browser history.
    I don’t think geoIP is the problem, at least it has an option to check its functionality and everything looks OK:
    Key Value Shortcode equivalent
    $record->city->name Alcalá de Henares [geoip_detect2 property=”city”]
    $record->mostSpecificSubdivision->isoCode M [geoip_detect2 property=”mostSpecificSubdivision.isoCode”]
    $record->mostSpecificSubdivision->name Madrid [geoip_detect2 property=”mostSpecificSubdivision”]
    $record->country->isoCode ES [geoip_detect2 property=”country.isoCode”]
    $record->country->name España [geoip_detect2 property=”country”]
    $record->location->latitude 40.482 [geoip_detect2 property=”location.latitude”]
    $record->location->longitude -3.36 [geoip_detect2 property=”location.longitude”]
    $record->continent->code EU [geoip_detect2 property=”continent.code”]
    $record->location->timeZone [geoip_detect2 property=”location.timeZone”]

    Definitely that hypothetical option of your plugin is not functioning at least in cases, and it doesn’t seem that neither VPN nor geoIP are the reason.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘GeoIP detect doesn’t work?’ is closed to new replies.