Support » Plugin: GEO my WordPress » Geocoder failed due to: Location information is unavailable.

  • Resolved Anticosti

    (@anticosti)



    Greetings,

    I so much appreciate this great plugin. It is the backbone of many projects I have in mind. I had to been away from my projects for sometimes and now I realize that it is not working anymore.
    I have been strugling pretty hard to get Geo my WP working back again.
    Whatever I do, I always get this error:
    Geocoder failed due to: Location information is unavailable.

    I tried on a fresh new WP 4.9.7 with no extra plugins;
    I even tried with the 3.1 Beta version;

    Just like with your demo site:
    https://demo.geomywp.com/
    It seems to be only working through Google Chrome.

    Don’t know now what could I do…?

    Here’s some vital info that may help…?

    
    ### Begin System Info ###
    
    Host Provider:			hidden
    
    ---------------------------------------------
    		** WORDPRESS DATA **
    ---------------------------------------------
    Multisite:				No
    SITE_URL:				https://www.hidden/geomywp
    HOME_URL:				http://www.hidden/geomywp
    WP Version:				4.9.7
    Permalink:				/%year%/%monthnum%/%day%/%postname%/
    Active Theme:			Twenty Seventeen 1.6
    Post Types:				post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, sg_optimizer_jobs
    Post Stati:				publish, future, draft, pending, private, trash, auto-draft, inherit, request-pending, request-confirmed, request-failed, request-completed
    User Count:				1
    
    ---------------------------------------------
    		** WORDPRESS CONFIG **
    ---------------------------------------------
    WP_DEBUG:				Disabled
    WP Memory Limit:			128MB
    Table Prefix:				geo_
    Prefix Length:			Acceptable (4 characters)
    Show On Front:			posts
    Page On Front:			n/a
    Page For Posts:			n/a
    
    ---------------------------------------------
    		** BROWSER DATA **
    ---------------------------------------------
    Platform:					Linux
    Browser Name			Chrome
    Browser Version:			67.0.3396.87
    Browser User Agent:		Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36 OPR/54.0.2952.60
    
    ---------------------------------------------
    		** SERVER DATA **
    ---------------------------------------------
    jQuery Version			1.12.4
    PHP Version:				7.0.30
    MySQL Version:			5.6.36
    Server Software:			Apache
    
    ---------------------------------------------
    		** PHP CONFIGURATION **
    ---------------------------------------------
    Safe Mode:				No
    Memory Limit:			768M
    Upload Max:				128M
    Post Max:				128M
    Time Limit:				120
    Max Input Vars:			3000
    Display Errors:			On
    Sessions:				Disabled
    Session Name:			PHPSESSID
    Cookie Path:				/
    Save Path:				/tmp
    Use Cookies:				On
    Use Only Cookies:			Off
    FSOCKOPEN:				Your server supports fsockopen.
    cURL:					Your server supports cURL.
    SOAP Client:				Your server has the SOAP Client enabled.
    SUHOSIN:				Your server does not have SUHOSIN installed.
    OpenSSL:				Your server has OpenSSL installed.
    
    ---------------------------------------------
    		** PLUGIN INFORMATION **
    ---------------------------------------------
    
    ------------------------
    Active Plugins: (3)
    ------------------------
    	- GEO my WP 3.0.5
    	- Jetpack by WordPress.com 6.3.2
    	- SG Optimizer 4.0.7
    
    ------------------------
    Inactive Plugins: (2)
    ------------------------
    	- Akismet Anti-Spam 4.0.8
    	- Hello Dolly 1.7
    
    ---------------------------------------------
    		** GEO my WP Data **
    ---------------------------------------------
    a:3:{s:16:"general_settings";a:5:{s:14:"allow_tracking";i:1;s:12:"country_code";s:2:"CA";s:13:"language_code";s:2:"FR";s:11:"auto_locate";i:1;s:12:"results_page";s:0:"";}s:13:"api_providers";a:4:{s:13:"maps_provider";s:11:"google_maps";s:18:"geocoding_provider";s:11:"google_maps";s:26:"google_maps_server_api_key";s:39:"AIzaSyDjYchGbelUpTJNJb5_E0VqQ6zKbYN7Cxw";s:15:"nominatim_email";s:18:"admin@iroutier.com";}s:19:"post_types_settings";a:5:{s:10:"post_types";a:1:{i:0;s:4:"post";}s:27:"edit_post_page_map_latitude";s:9:"40.711544";s:28:"edit_post_page_map_longitude";s:10:"-74.013486";s:23:"edit_post_page_map_type";s:7:"ROADMAP";s:29:"edit_post_page_map_zoom_level";s:1:"7";}}
    
    ---------------------------------------------
    
    ### End System Info ###

    Sorry about this long post 🙁

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Eyal Fitoussi

    (@ninjew)

    Hi Anticosti,

    The error you mentioned usually indicates on missing SSL certificate.

    Nowadays, most browse require a secure page in order to use the auto-locator feature.

    You will have to install SSL certificate on your site to make the auto-locator work.

    BTW, if still possible, you should remove the site information you posted above. You usually should sent it directly via email or post it where you can mark it private.

    Anticosti

    (@anticosti)

    Hi Eyal,
    Thank you for your quick reply.
    Can’t find the way to delete the above info…? 🙁

    I do have a valid SSL Cert:
    Let’s Encrypt Authority X3

    Anticosti

    (@anticosti)

    Is it possible for you to delete this thread?
    I don’t have access to any edit button… 🙁

    Plugin Author Eyal Fitoussi

    (@ninjew)

    @anticosti,

    Unfortunately, I don’t have access to edit your posts. I think there is a time limit ( maybe 15 or 30 ) which you can edit your own post after posting it. Now, it is only a moderator can edit it.

    However, you shouldn’t worry too much. There isn’t any sensitive information in there. Moreover, I noticed that you removed the URL of your site, which is good.

    As per your issue, this might be a “mixed content” error.

    Please see this post for a possible solution.

    Let me know if this helps.

    Anticosti

    (@anticosti)

    Thank you Eyal. Your kind help is again very much appreciated.

    I will check your link and see what I can do…
    I’ll let you know.
    Meanwhile, I swapped my api_key for a new one.

    It is working on:

    • IOS Safari
    • Ubuntu Google Chrome

    Not working on:

    • IOS Google Chrome
    • IOS Opera
    • IOS Firefox
    • Ubuntu Fifefox
    • Ubuntu Opera

    Sadly, and… exactly the same issue and behavior as for your site’s main page:
    https://geomywp.com/
    It throws this error:
    Geocoder failed due to: Location information is unavailable.

    and on your demos:
    https://demo.geomywp.com/
    https://demo.geomywp.com/post-types-purple-search-form/
    It throws this error:
    Geocoder failed due to: Location information is unavailable.

    I will have to meditate on this…

    Kindly,

    Now solved.
    Check my reply hre for the conclusion:
    https://wordpress.org/support/reply/10534202/

    Cheers,

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.