Support » Plugin: Brilliant Geocoder for Gravity Forms » Geocode Engine option not showing up

  • Hi! This plugin looks like it might solve a lot of problems for me but I’m trying to set up and it doesn’t seem to work at the moment. The “Geocode Engine” option doesn’t show up if that puts you on the right path. I’ve added keys for both google and .io as well as set up OSM email.

    Thanks,
    Sam

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Michael Moore

    (@stuporglue)

    Hi Sam,

    I’ll be able to take a closer look on Monday, but in the mean time if you can let me know which version of Gravity Forms and WordPress you have installed, that would be helpful.

    Thanks,
    Michael

    Sam Hatton

    (@sam-hatton)

    Gravity Forms 2.1.3
    Wordpress 4.8.1

    Plugin Author Michael Moore

    (@stuporglue)

    Sam,

    I don’t have a copy of GF 2.1.3 around, I’m using 2.2.5.5 for development and the oldest version I have handy is 2.2.3.

    I’ll start saving versions now, so that in the future I’ll be able to help people who aren’t up to date, but of course that doesn’t help you today.

    So…

    1) You’re looking for the “Geocoder Engine” on the individual form’s setting page, right?

    Each form can use a different Geocoder, so those settings are on the individual form’s setting page.

    2) Do you have WP_DEBUG enabled?

    Are you comfortable enabling it? Instructions are here: https://codex.wordpress.org/WP_DEBUG

    If you can enable it, and after you visit an individual form’s settings page, is there any output in debug.log that looks relevant?

    3) Are you able to upgrade Gravity Forms to the latest version?

    At least on a test server, if not on production.

    Thank you,
    Michael Moore

    Sam Hatton

    (@sam-hatton)

    I didn’t see anything in the log that jumps out but I might not be the best person to look.
    I added a child theme and it showed up for whatever reason. But, (I have your plugin set to lat, lon) it doesn’t propagate in the post type after adding address. I have the setting to i.o. full address.

    Sam Hatton

    (@sam-hatton)

    I was able to kind of get it working but the output is the GeoJSON code. I was hoping for just the coordinates.

    Plugin Author Michael Moore

    (@stuporglue)

    I was able to kind of get it working

    If you can, could you please share what you did in case other users end up in the same situation?

    but the output is the GeoJSON code. I was hoping for just the coordinates.

    Yes, the stored value is GeoJSON. This plugin can be used to create Posts or Users with WP-GeoMeta compatible spatial metadata.

    Also, some geocoding services could return polygons, which wouldn’t work with coordinates. Eg. If you tried to geocode the word “Minnesota” it might return a polygon of the state boundaries.

    The admin view of entries should show the coordinates for points though, and if you need to edit an entry you should be able to edit the lat/lng and new GeoJSON will be generated.

    If you do need or want the value to be stored as lat/lng, you could use the GravityForms gform_pre_submission hook to modify the values however you want.

    Eg. You could have two hidden fields for lat/lng that don’t get set during form submission, and then use the gform_pre_submission hook to json_decode the geojson and set those fields.

    That would require some programming, but it is an option.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Geocode Engine option not showing up’ is closed to new replies.