Support » Plugin: GEO my WordPress » Geo my WP search form not working after removing www. from site address.

  • Resolved scuffed

    (@scuffed)


    Hi Geo my WP support team, my question is regarding the Geo my WP search form not working after I changed my WordPress site address under “Settings” > “General” on the Admin dashboard. All I did was remove the www. from my domain (scuphed.com). I have changed the URLs connected to the google maps keys and done the test in the Geo my WP settings to make sure the keys are working properly and they are. I have also deactivated/reactivated the core Geo my WP widgets and cleared their cache, as well as uninstalled Geo my WP through the settings and reinstalled the whole thing fresh, but nothing has worked. As you can see on the page linked if you scroll down the left sidebar contains a product location form widget which is displaying errors. Any ideas why this may be happening?

    Thanks for your time.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Eyal Fitoussi

    (@ninjew)

    Hello @scuffed,

    The error on your site is related to your Google Maps Browser API key and most likely caused by removing the www from your site.

    You need to reauthorize your site’s URL in your Google Maps Browser API key console.

    Please see step 8 of this tutorial to learn how to autorize your site’s URL. Make sure that the URL that you enter does not include the www.

    I hope this helps.

    Thread Starter scuffed

    (@scuffed)

    Hi Eyal,

    Thank you so much for your response. I actually already did reauthorize the URL’s for my browser API key but that did not solve my problem. However, thanks to you saying that was likely the source of my problem I more thoroughly checked my keys and found that I had to remove the asterisk and period from my URL for it to work, which is strange because when the www. was there originally I needed the asterisk and period for the URL’s to work. Regardless, I would have never found that without you pointing me in the right direction and I hope my observation can help others in the future.

    Thanks so much for your help and your amazing plugin, Scuffed

    Plugin Author Eyal Fitoussi

    (@ninjew)

    You are very welcome, @scuffed.

    I am glad I could help :).

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Geo my WP search form not working after removing www. from site address.’ is closed to new replies.