Support » Plugins » gengo requirements – crashing

  • Hi
    We have just moved server, to a dedicated server. The database transfer seemed to work well, but unfortunately the blog part of our site is creating problems, with Gengo I think.

    To test, I just created a parallel install of a new wp blog, which works until I enable Gengo, upon which I get error 500 – internal server error.

    removing the gengo plugins folder, all is OK again.

    We are on IIS7 on a windows host.
    So far as I can see, all necessary permissions are OK, Internet user can create and upload graphics, etc, this all works OK.

    It occurs to me though that the php.ini may need a tweak? Or some other setting? Gengo worked well for us with exactly the same wordpress install, on our previous host, also under windows.

    The only extensions I have enabled are the gd2 and mysql dlls.

    In MySQL, the bloguser has all permissions apart from DROP, LOCK_TABLES, CREATE_ROUTINE, ALTER_ROUTINE, and EXECUTE. Does it need these?

    Many thanks for any ideas.

    Further to the above, I just went to change theme from the default, and the same “internal server error” – so its not just gengo.

Viewing 6 replies - 1 through 6 (of 6 total)

    Some errors above were due to attempting to install my theme (which has gengo tags). Once I’d removed these, the theme installed OK.

    Activating Gengo gives me the following error:

    WordPress database error: [BLOB/TEXT column ‘description’ can’t have a default value]
    CREATE TABLE wp_term2syn ( term_id bigint(20) NOT NULL default ‘0’, language_id tinyint(3) NOT NULL default ‘0’, synonym varchar(55) NOT NULL default ”, sanitised varchar(200) NOT NULL default ”, description longtext NOT NULL default ”, PRIMARY KEY (term_id,language_id) ) TYPE=MyISAM

    Reading up on this, it seems that this may be happening because we are in strict mode on sql (I haven’t a clue what that means – do we need it?)



    This is from the error log on attempting to save an existing post after adding tags to it:

    [05-Mar-2009 16:39:31] WordPress database error Field ‘description’ doesn’t have a default value for query INSERT INTO wp_term2syn (term_id, language_id, synonym, sanitised) VALUES (1267, 2, ‘problems’, ‘problems’),(1267, 5, ‘problems’, ‘problems’),(1267, 6, ‘problems’, ‘problems’),(1267, 7, ‘problems’, ‘problems’),(1267, 8, ‘problems’, ‘problems’),(1267, 9, ‘problems’, ‘problems’),(1267, 10, ‘problems’, ‘problems’) made by create_term

    OK, the above errors were fixed by removing STRICT_TRANS_TABLES from the MySQL initialisation. Also the tables had been created as InnoDB, changed default to MyISAM

    However – I am still experiencing the following:

    – Automatic language selection in “add language” does nothing – it just sits there.
    I can’t imagine this is a server thing ?

    – clicking to remove a post from a translation group goes to white screen, the post isn’t removed. This is needed because …

    – duplicates are always added to translation groups, looking at the database tables it looks like these are from the autosaved versions of posts.

    No errors or warnings are recorded on the server log for this.

    Any ideas / help much appreciated – thank you.

    This may be useful for others on IIS7 (like us)

    This has been so frustrating because we moved a functioning blog from IIS6 to a new server with IIS7 – and it fell over.

    This topic explains why you may be getting white screen on attempting to delete posts:

    and the necessary server hotfix from Microsoft (its a bug in IIS7 )

    The Gengo plugin is still not functioning correctly, see below, but at least most of the rest of the blog is.

    – Add language dropdown doesnt work. Nothing happens
    – duplicate translations always added, from autosaved post versions.
    – paging not working (language code isnt included)

    we know that gengo is highly broken, and I’m trying to do what I can. unfortunately can’t estimate a beta release at this time.

    Any news about gengo beta?
    I see no activity at the gengo hackers google group. Is it still in development?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘gengo requirements – crashing’ is closed to new replies.