Yoast SEO
Genesis Framework breadcrumbs missing (11 posts)

  1. Fawk
    Posted 2 years ago #

    Hi, after updating to the latest WordPress SEO plugin, breadcrums on Genesis went missing. This is what I got from StudioPress:

    With the Yoast SEO plugin enabled, it currently isn't respecting our filters. With breadcrumbs in the plugin disabled, they just don't output.

    Any ideas?


  2. sokratesagogo
    Posted 2 years ago #

    Same problem -missing Genesis breadcrumbs after last SEO update.

  3. Tschoepler
    Posted 2 years ago #

    For the moment, I just activated breadcrumbs in Yoast SEO (under “Internal Links”) and it seems to work like before. Don't deactivate the breadcrumbs in Genesis’ options panel though.

  4. sokratesagogo
    Posted 2 years ago #

    Thanks Tschoepler. Didn't work for me unfortunately. I read Yoast's sticky post and had a look at the plugin's GIT issue tracker, and have created a support ticket with StudioPress.
    Cheers :)

  5. Fawk
    Posted 2 years ago #

    Thanks Tschoepler, that worked.

  6. signcarver
    Posted 2 years ago #

    This is also an issue with Catalyst/Dynamik frameworks.

    Tschoelper's fix worked for me.

  7. HeavyDigital
    Posted 2 years ago #

    Breadcrumbs continue to be broken in WordPress SEO and Genesis Framework 2.0.2

    This is a WordPress SEO plugin issue, not a Genesis issue, as the plugin is disabling the Genesis breadcrumbs when WordPress SEO breadcrumbs are disabled. This behavior did not (and should not) occur.

    Additionally, if WordPress SEO breadcrumbs are activated, it does not display the entire path, but only home and the last page, excluding any sub pages between home and the page (IE: If a page is at /depth1/depth2/ it would display Home > Depth 2)

    Any help in resolving this would be greatly appreciated. We're using this on a production site and currently our breadcrumbs are disabled completely because of this.

    Please feel free to reach out if you want any help troubleshooting this, or need any additional information.

  8. HeavyDigital
    Posted 2 years ago #

    I know that sokratesagogo opened a ticket with StudioPress (Genesis) but I submitted a bug report on the GIT tracker, as this is a plugin issue, not an issue with the Genesis Framework

  9. sokratesagogo
    Posted 2 years ago #

    Whoops, forgot to post StudioPress response:

    "For now, if you want to use the WordPress SEO plugin, you will have to enable Yoast's breadcrumbs.

    If this causes design issues or you would prefer to use the Genesis breadcrumbs, you could roll back to an older version of the WordPress SEO plugin for now. Older versions are available at https://wordpress.org/plugins/wordpress-seo/developers/"

  10. sokratesagogo
    Posted 2 years ago #

    In the end I just pasted the jrfnl 's code into my theme's function.php

    This did the trick for me.

    GitHub Link

  11. alphablossom
    Posted 2 years ago #

    I tried jrfnl's code from github and couldn't get it to work with my Genesis theme.

    I ended up adding a function to my functions.php that checks if Yoast is active and if the 'use yoast breadrumbs' checkbox IS NOT checked, it replaces the default Genesis breadcrumbs with a new Genesis breadcrumbs function that removes the yoast function. These two functions were added to my functions.php file so no modifying of core files.

    Here's the article and code if it helps:
    Restore Genesis Breadcrumbs over Yoast SEO

    Hope there's a fix in Genesis 2.1 (should be out soon), but until then this works for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic