Support » Plugin: LifterLMS » Genesis, Course Categories, & Descriptions

  • Resolved Brad Griffin

    (@burlesonbrad)


    I spun up LifterLMS running Genesis Sample Child theme real quick. After creating several courses, gave ’em categories, and viewing the .com/course-category/inventory/ page, I noticed that the only thing echoing out onto the /course-category/ pages was simply the title.

    For semantic and SEO reasons, I always make sure woo categories, post categories, woo sub categories, ….everything else, is correctly optimized with content. I’ll even cheat sometimes and use https://github.com/sheabunge/visual-term-description-editor

    Ok, now in the admin site we’re gonna add content http://prntscr.com/cgzen8 so that our course’s category page looks sharp to visitors and great to google.

    Yet when we visit the site, here’s what I’m looking at.

    Any idea why the category description isn’t there?

    If this is a Genesis specific issue, that’s fine. I’m somewhat new to Genesis, & I thought it’d be fun to try.

    Any idea why the course category description isn’t echoing out on the course category page?

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    Hey @burlesonbrad,

    I do not claim to be a Genesis user, I fumble the best I can to keep as many theme zealots as happy as possible and theme compatibility is just one of the many many items on my backlog that I simply don’t have the time in the day to get to.

    I really have no idea what the sceenshot you’ve shared is a screenshot of and, therefore, I really don’t know how to go about recreating the issue to determine if this is our fault or not…

    By default, WordPress says “The description is not prominent by default; however, some themes may show it.” when adding a category description. And we have NO code in place to add this description.

    If the field is a Genesis field I’d take this question to Studio Press support or documentation as that’s not something I’m going to be able to advise you on.

    We DO NOT touch SEO. I can cite a hundred reasons why we don’t. We’re not going to. If, however, we’re doing something that interferes with Genesis SEO or with YOAST or something, I’ll do my best to get that resolved. If that’s the case please help me out and let me know EXACTLY what we’re breaking and I’ll do my best to resolve ASAP.

    Thanks,

    I think the key to figuring out this bug would be in the template that renders the /course-category/ page.
    The screenshot was of this page: /wp-admin/term.php?taxonomy=course_cat&tag_ID=20&post_type=course
    So, in the case of recreating, you’d go to http://prntscr.com/ch9zw5 LifterLMS > Course Categories

    Then when you fill up that area with content, like this http://prntscr.com/cha13o
    While I don’t want to post an actual link here, you can see that screenshot’s slug was /inventory, right? Consequently, on the page https://yourawesomesite.com/course-category/inventory/ you’d open it up and see the content that was entered earlier in the Content Description of that particular category.

    What’s happening now is that the page template that creates the /course-category/category_slug is simply echoing out the courses ~ like this: http://prntscr.com/cha2t0

    Unfortunately, I know it’s not Genesis. I can create a post category like this: http://prntscr.com/cha3f4 with content entered in the description area like this: http://prntscr.com/cha3mx and the Genesis framework aptly outputs the Category Description Correctly like this: http://prntscr.com/cha65z

    I’ll run over to the Github and look, as well as inspect Genesis again.

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @burlesonbrad,

    Give this a shot: https://gist.github.com/thomasplevy/dd97c7ccc78e9cf56627aeccbde02743

    Added to theme/child theme functions.php file

    That should do the trick,

    if only “getting close” actually worked in the land of code… 😉
    Here’s what I had —> http://prntscr.com/chaaip

    Sometimes I wonder why I don’t BAN MYSELF from opening up Atom or Git!

    Thank you! That worked perfectly! lifterlms_archive_description was the piece I was missing!

    • This reply was modified 3 years, 1 month ago by  Brad Griffin.
    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    cool, resolved then??

    Yes sir!
    Wait, didn’t the thread author have the option of “Resolved”?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Genesis, Course Categories, & Descriptions’ is closed to new replies.