Support » Plugin: MailUp newsletter sign-up form » Generic Error – IP auth

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author MailUp

    (@mailup)

    Hi Luca, here is how you can handle that:

    – Log into your MailUp account
    – Navigate to Settings > Account settings > Developer’s corner > Web services*
    – Select Frontend from the drop-down
    – Check the “Enabled**” checkbox
    – Uncheck “IP Address Validation”
    – Don’t forget to press “Save”

    *ITA Configurazioni > Gestione console > Avanzate > Web services
    **ITA Abilita web service

    Thread Starter Pilz2772

    (@pilz2772)

    I’ve done it but I get “Generic Error”.
    It doesn’t work.

    Plugin Author MailUp

    (@mailup)

    Hi, the “Generic Error” message is returned when MailUp does not accept the subscription request. If you are able to get there the plugin should have worked fine.
    Please check these common configuration issues:
    – you are trying to subscribe a recipient by specifying an invalid pair of email and phone number (e.g. you are specifying an email that has been already inserted for subscriber A and a phone number that belongs to existing subscriber B. In this case MailUp is unable to understand if you are trying to update A or B).
    – specified ID for list or group does not exist
    – other configuration parameters are not valid

    If you don’t manage to solve this case you can contact our support team providing details about your account and the configuration you specified.

    Hope this helps

    Regards

    Thread Starter Pilz2772

    (@pilz2772)

    Thnks but before this last update, plugin worked well. So I don’t think it’s a configuration issue. I’ve not changed anything.
    I don’t know if something is changed on the Maiulp server side.

    Thank you.

    Plugin Author MailUp

    (@mailup)

    Hi Luca, let me ask you if you are configuring properly the field codes. As shown in http://help.mailup.com/display/mailupUserGuide/WordPress#WordPress-PersonalDataFields, allowed field codes require the “CampoN” syntax, where N is the field ID. You cannot use the field names that are specified on MailUp console. Writing field name where field code is required is a misunderstanding that could lead to “Generic Error” messages.
    Please let me know it this is helpful for you
    Regards

    Thread Starter Pilz2772

    (@pilz2772)

    Solved.

    Thank you for your support.

    Have a nice week!
    Best Regards.

    Luca

    Hi, i have the same problem
    Whit the test this is the error:
    IP address validation is required. Please check this page

    I have Enabled the IP address but the error is the same.
    Thanks
    Federico

    Plugin Author MailUp

    (@mailup)

    Hi byfede80,
    Here are some troubleshooting tips:
    1) if you temporarily uncheck “IP Address Validation” you should successfully complete the subscription. If you are still receiving the error you reported above please double check the second comment in this page, otherwise contact MailUp support.
    2) then add your server’s IP, check “IP Address Validation” and finally press “save”. The subscription will be allowed only to calls coming from that IP.
    3) If step #2 is successful you’re done, otherwise it should be something related to an outcoming IP that is actually different from the specified one. If this is the case, could you please contact the MailUp support providing your host name and the IP address you specified on that page?
    Regards,

    Thanks,
    now the plugin is ok, but only with email Field.
    If I use another field (present in the admin area of mailup) the plugin get me generic error.

    Plugin Author MailUp

    (@mailup)

    Hi byfede80,
    A generic error could be returned in one of these cases:

    • one of the additional fields is the phone number and you are inserting a value mismatch (e.g. you’re inserting a phone number together with an email address that was previously linked to a different mobile number). You could access to the web application and “delete” old test recipients. This may help you to start from a clean situation
    • you’re not following the “campoXY” syntax. Reference: http://help.mailup.com/display/mailupUserGuide/WordPress#WordPress-PersonalDataFields

    If none of these tips is helpful for you, I suggest you to take some screenshots of your configuration and send them to MailUp support for help.

    Best,

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Generic Error – IP auth’ is closed to new replies.