WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Generating Preview Black image (11 posts)

  1. Nick2102
    Member
    Posted 2 years ago #

    When i am posting links on Facebook , and also when someone likes a post the thumbnail show a black picture with the wordpress logo saying generating preview . So I am wondering why is that ? Can it be removed ?
    Or maybe some plugin is responsible for that ?

    The photo comes from this LINK

    It says that this is a safe picture ...

    Can someone please explain me what is this all about.

    Thanks

  2. Nick2102
    Member
    Posted 2 years ago #

    This is the LINK of my site

  3. Peetra
    Member
    Posted 2 years ago #

    Thank you for writing it here, it feels nice that somebody else is having this very same issue getting only the Black preview image at Facebook. They are such UGLY!

    I have the same problem, it might be an server/facebook combo issue or a plugin issue. Here is a list of my Plugins. Is any of them matching your Plugins, Nick2012? (I already tested to turn on/off the cache plugin, that didn't seem to help)

    Akismet
    Google Translator
    Google XML Sitemaps
    Peetra's Custom Made Editor Addons
    Really simple Facebook Twitter share buttons
    SEO Ultimate
    Simply Poll
    WP Super Cache
    WP Video Lightbox

    I also recently have had "PagePressApp.com Auto Wall Post" on my WP blog/FB Page, it was never working properly and when the black pic-issue turned up about 4 days ago I turned the Auto Wall post off.

    As a temp fix I was thinking of replacing the black pic with something more proper for my site. But I haven't yet found it to test this. Anybody knows where it is located? It is not the photo located at facebook that you posted, nick2012. The image is somewhere in our own directories, but WHERE?, it is the same pic used for generating previews when somebody have made a faulty URL in comment form's and you can see it inside your Admin Panel when hoovering over a faulty url in a comment.

    Another temp fix that I have made for one important post (that should be shared/liked at least 100 times at Facebook) was that I made a static html-file before posting my blog post. I shared the link to the static file at Facebook myself making Facebook cache my desired Pic from that URL. I then deleted the static file and renamed my post's url to what I already had sent to Facebook. Problem solved for that particular post at least.

    Facebook cache's preview pics quite long, about 4 days I have noticed. So the workaround I made is fine for important posts, as the news value for me is over in 7 days anyway. But I wasn't really signing up for making static html files manually when starting to use WordPress, LOLs, so my workaround isn't desirable.

  4. Nick2102
    Member
    Posted 2 years ago #

    Only the SEO Ultimate plugin match with one of yours .
    And yes I think that the thumbnail comes somewhere from our directories too , but i cant find it anywhere.

  5. Peetra
    Member
    Posted 2 years ago #

    That is the issue, I am trying different versions of it as I write. Deactvating did help in that way that it didn't post any thumbs at ALL. I haven't tried complete uninstall yet.

    Version 7.5.3 (August 11, 2012) do not work and it goves me following error;

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'SU_MetaKeywords' does not have a method 'postmeta_help' in /home/peetra/public_html/bubble-witch-saga.se/wp-includes/plugin.php on line 170

  6. Peetra
    Member
    Posted 2 years ago #

    I ended up removing it and now I am getting no thumbs at all, swell, ain't it? :P

  7. Nick2102
    Member
    Posted 2 years ago #

    i 've removed seo ultimate but still getting the black thumb ...

  8. Peetra
    Member
    Posted 2 years ago #

    Make a NEW post and then post it to Facebook. The old posts are still cached on Facebook.

    My complaints about the "no thumbs" at all after unistalling SEO plugin seem to have corrected itself before I had the time to look into it, my site is all good now! WOOP, WOOP!

    (Another story though if I am gonna drop on google now... I have about the same amount of visitors from FB and Google so it would be essential to keep both places in shape)

  9. Nick2102
    Member
    Posted 2 years ago #

    Well i have found from where the thumb comes from :)

    It can be modified in the Open Graph Module in the Default Values tab . Now you can install the plugin and disable the module or you can put link from your own default image. :)

    Can be seen from this PICTURE

    Best regards

  10. John
    Member
    Posted 2 years ago #

    As Nick2102 indicated, if you don't specify a default image under SEO > Open Graph > Default Values > Default Image, then SEO Ultimate will use the WordPress.com mShots service to generate a screenshot of your site. However, if this is the first time that WordPress.com mShots has had to generate a preview of a given webpage on your site, then it will show the "Generating Preview" image. Unfortunately this is what Facebook picks up in those cases. I'll look into a solution, but for now, the workaround would be to specify an image under the Default Image box.

    @Peetra: Upgrade to the latest version of SEO Ultimate to remove the Meta Keywords error.

  11. Peetra
    Member
    Posted 2 years ago #

    Thanks Nick2012 and John Lamansky. :) But I'll go without the Plugin for a while in testing purpose. I actually have really good placing in most countries google right now and as I am not depending on google visitors it should be interesting too see how or if the visitor amount from google change compared to the whole visitor amount. :)

Topic Closed

This topic has been closed to new replies.

About this Topic