Support » Plugin: URL Shortener » "Generating…" error occurs

  • Resolved mspecian

    (@mspecian)


    After submitting a post, the shortened URL should appear at the bottom of the post. However, the recent plug-in upgrade has caused the shortlink to be replaced by the word “Generating…” This is also a link, but it leads nowhere. The automatically generated Twitter feed contains a correct shortened URL, but my posts themselves do not.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Gerald

    (@geraldyeo)

    Is this across all posts or only just pages?

    And which URL Service are you using it on?

    I’m using it on bit.ly.

    I tested it on a page yesterday and it worked fine. I tested it on a new post this afternoon and it also worked fine. Strange. Check my homepage http://www.mikespecian.com/ for the three posts on and preceding July 31, 2011 and you’ll see what happened.

    The only thing I did differently with the post that worked (as far as I can tell) is that I waited a few moments before I clicked on “view post” to see my newly published article and associated short link.

    Plugin Author Gerald

    (@geraldyeo)

    Hmm.. that’s weird..

    For now, try removing the shortlink for those post with “generating…”It should re-generate properly after that…

    I’ll do some code shifting in the next update which hopefully would hopefully mitigate the chances of this occurring…

    How do I remove shortlinks for individual posts?

    Plugin Author Gerald

    (@geraldyeo)

    Hi mspecian,

    In your post list, you can make use of the bulk deleting function to remove the shortlink..

    For more info, check the wiki at: http://wiki.fusedthought.com/docs/url-shortener-wordpress-plugin/version-4#TOC-Bulk-Deleting

    Thanks, that worked exactly as described!

    Gerald ,

    I am getting that problem on almost every post creation. Of-course , I could able to reset them by using “remove shortlink” option.

    Just looking forward for the permanent fix 🙂

    Plugin Author Gerald

    (@geraldyeo)

    @vbk100:
    The issue is noted, but I haven’t had the time to test out the issue extensively as I am still studying and school is really piling up on assignments. The earliest I can push out an update would probably be after the end of my school semester.

    petethechop

    (@petethechop)

    You say this issue is “noted” but it still doesn’t appear in the “Known Issues” documentation. I just had this problem with every page/post and it has been 6 months since it was “noted.”

    Only the first and last post and page had the correct short link. Bulk Deleting the short code worked great, but it took me over 24 hours to realize that “Generating…” was happening.

    I know you are making a complete rewrite of this plugin, but maybe you could make the issue more known for the current version.

    Thanks.
    Jason

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘"Generating…" error occurs’ is closed to new replies.