Support » Plugin: Woocommerce Google Feed Manager » Generates Feed but Status keeps on Failed processing

  • Resolved lucasmdiniz

    (@lucasmdiniz)


    First of all, thanks for the great plugin!

    My issue is that the plugin generates the feed when I click in “Regenerate”, but the status is always “Processing failed, please try again”.

    The problem is that the feed doesn’t auto update with this status.

    Could you help me?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Hello @lucasmdiniz,

    Does it update when you open the feed in edit mode and select the “Save & Generate Feed” button?

    Also, could you check the steps in this FAQ list:https://www.wpmarketingrobot.com/support/faq/#toggle-id-16 ? Usually the first steps solve the issue.

    Let me know the results.

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Hi @lucasmdiniz,

    Where you able to solve the issue?

    @michel-jongbloed I believe I’m having the same issue as @lucasmdiniz so I’m sharing my findings to hopefully help. My feed is here. I have completed FAQ steps 1-10. Here is a screenshot of the console results, I don’t see any errors. It looks like the feed was generated but I still get the error.

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Hi @oovoadmin,

    Indeed it looks as if the feed is OK. Could you try if you can generate the feed using the Save & Generate Feed button on the Edit Feed page?

    In the mean time I will see if I can identify any issues with the status reporting part of the code.

    Hi @michel-jongbloed,
    Yes, I tried the Save & Generate Feed button as well and I got the same error.

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    @oovoadmin,

    Could you try to open the wp_feedmanager_product_feed table from your database, edit the row where the product_feed_id is 3 and on that row change the status_id to 2?

    Then refresh the feed list. The feed should now indicate it is Ready (manual). Then try to regenerate it and let me know the result.

    Hi @michel-jongbloed if you’re talking about editing database files outside of the wordpress interface, that’s a little beyond my abilities. I can give it a shot but if there’s a way to achieve this within wordpress cms please let me know.

    Hey @michel-jongbloed

    Sorry for my late reponse. I’ve gone through the steps but it didn’t work. I’ll try to change the wp_feedmanager_product_feed table and let you know if it works.

    Thanks!

    Here is how my wp_feedmanager_product_feed table looks like:

    https://calcadosnovaserrana.online/wp-content/uploads/2019/10/Untitled.png

    This is the only row, I do not have a row where the product_feed_id is 3. Is that right?

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Hi @lucasmdiniz,

    Yes that’s right. I saw on the feed data from @oovoadmin that the feed id of his failing feed was 3, so that was only for his database. So for you the only row is the correct row. If you change the status_id from that row, from 6 to 2, your feed should indicate Ready again in the Feed List. Let me know if regenerating the feed keeps working correctly after that.

    @oovoadmin, I’m looking for a way to reset that row without you having to edit the table. I hope to have a solution end of the day.

    I’ve made the changes and it looks like everything is working!

    Thank you for such a great support even in the free version of the plugin.

    Best regards.

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    @lucasmdiniz,

    You’re welcome. Thanks for the compliment!

    @oovoadmin,

    Although I could make a small code addition for you to reset the database setting, I would prefer to use another way if it’s OK for you. If the feed is not to complex, could you please make a new version of it and generate that new feed? So just take over all the feed settings from the failing feed and then generate that new feed. That should solve the issue without any changes to the database.

    In the mean time I think I identified the cause of the issue and will have a solution to prevent this from happening in the future. This solution will be implemented in the next update, expected to be released within two weeks.

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    @oovoadmin,

    Where you able to solve the issue by generating a new feed?

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Hello @oovoadmin,

    I hope we were successful in helping you resolve your issue with our Feed Manager plugin! Since we have not heard back from you in the past 2 weeks and we don’t want to leave tickets open forever, I will now be marking this support topic as resolved. However, if we still haven’t resolved your issue please reach out to us as we would be more than happy to further assist you!

    Thanks and have a great day!

    creativenl

    (@creativenl)

    I also had this problem. Changing the status from 6 to 2 helped to get the feed-status to “Ready” (Gereed-Handmatig).

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.