Support » Plugin: Shield Security: Protection with Smarter Automation » Generatepress conflict?

  • Hi,

    Is there any known conflict with GeneratePress theme? When I have it installed I get the following error

    The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

    If I change my theme then the error goes away. I have tried deactivating / deleting Shield along with removing all icwp tables and options from the database but I continually get the same error.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I correct myself:

    The error is with this line

    public function __construct(?string $locale, MessageFormatterInterface $formatter = null, string $cacheDir = null, bool $debug = false)

    in this app file

    modern-events-calendar/app/vendor/symfony/translation/Translator.php

    The developer says it is a popular and common library and is not an issue. However, it breaks my Shield security. If I disable the plugin then I can access Shield but this is not ideal.

    If I make a copy to a staging site the issue goes away (that’s where I changed the theme for the previous conclusion). But if I try the combo on a fresh site install I get the same error.

    Not sure what to do now!

    • This reply was modified 2 months, 3 weeks ago by Jason Chong.
    Plugin Author One Dollar Plugin

    (@onedollarplugin)

    Hi,

    Sorry to hear about your trouble. Why do you feel this is a Shield Security issue to resolve?

    You mentioned you continue to get the problem even after deactivating Shield and the error isn’t generated from Shield itself. I’m honestly not sure how we are to help with this…

    You also didn’t tell us what the actual error is…

    Hi. To clarify it is a issue that shield picks up which comes from my other plugin (modern event calendar). I don’t think it is an issue with shield itself.
    I included the line previously from the other plugin which the error in shield refers to. The developers of the other plugin states it is standard code from a common library and therefore shouldn’t cause an issue.
    My query is to if you have come across this before and therefore may have an insight into solution.
    As I mentioned the very weird thing is that if I create a staging site from my site (ie staging2.XXX) then the issue does not exist. However I also tried to create a fresh WordPress install with just shield and modern event calendar installed and came up with the same error.

    • This reply was modified 2 months, 3 weeks ago by Jason Chong.

    Hmmm. To make it even weirder I disabled Shield last night and installed a different security plugin to test. I came back to it today and reinstalled Shield and now the problem is not occurring. I guess that means its resolved for now!

    Plugin Author One Dollar Plugin

    (@onedollarplugin)

    What exactly was the php error?

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.