Support » Plugin: Media Library Assistant » Create Alt text when uploading from IPTC is not longer working

  • Resolved elotse

    (@elotse)



    I use the plugin to automatically generate Alt text when uploading from IPTC. Until one of the last updates this worked.
    The same function for generating the description still works.
    The setting is 2#120 caption-or-abstract

    • This topic was modified 2 months, 3 weeks ago by  elotse.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author David Lingren

    (@dglingren)

    Good to hear from you again! Thanks for your report, and for including a link to the page on your site; very helpful. I don’t understand German, but the food looks great.

    I downloaded the full-size image file associated with your “Basilikum-Pesto – Pesto alla Genovese selber machen” recipe; file name “cuisine-2018-04-24-10-49-24.jpg”. I created IPTC/EXIF mapping rules for the ALT Text and Description fields and then uploaded the file to my test system. Both the ALT Text and the Description values were set to “Basilikumblätter abzupfen und mit einem Küchenmesser klein hacken”. As far as I can tell, the ALT Text mapping is working correctly.

    If you can post a link to one or more image files that are not working for you I can investigate further. Also, if you can post the full details of your mapping rules for the ALT Text and Description fields I can make sure my rules match yours and I am testing the same thing. Any additional information you can provide will be helpful; thanks.

    Hello David, Thanks for the quick response.
    I have now taken the test with the same picture. Unfortunately, no alt text is generated!
    Now I have tested the following:
    1. All other plugins disabled, unfortunately without success.
    2. My WP version is 4.9.8
    3. Two other websites with the same themes (kk4you.de and msr-support.de) also have the same effect there
    4. Until 25.11.18 everything had still worked
    5. No changes were made after 25.11
    6. I have made a print screen of the settings and would like to send it to you. Please let me know your mail. My mail is klaus@msr-support.de

    ??????? Strange

    Plugin Author David Lingren

    (@dglingren)

    Thank you for working with me offline to find the cause of this problem and resolve it.

    MLA is working properly. You are using an image optimization plugin, Optimus – WordPress Image Optimizer (the HQ version), which is removing the IPTC metadata from the image file before MLA runs the mapping rules. I verified this by testing the free version, and I also discovered an alternative that will address your specific problem.

    The “IPTC 2#120 caption-or-abstract” is used by WordPress to populate its “caption” value in the image metadata array, and this is done before the optimization. You can access this value in your mapping rule using a Content Template in the EXIF/Template Value. Simply enter template:([+meta:image_meta.caption+]) in your rule’s EXIF/Template Value text box. This works fine on my test system and should work for you.

    I am marking this topic resolved, but please update it if you have any problems or further questions regarding your mapping rules or the above suggestion. Thanks for your help and for your interest in the plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.