Support » Plugin: WordPress RSS Feed Retriever » Generally Good but…

  • It works well in general, but the “excerpt” attribute doesn’t work when the feed contents are not in English.

    We tried in both traditional Chinese and simplified Chinese both give no response under your “excerpt” attribute.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Travis

    (@tjtaylor)

    Hello, can you post the shortcode you’re using so we can try debugging?

    Thanks!

    Thanks for being so responsive. I realized that you just posted an update. I tried again on the feed after updating the plugin, but it still doesn’t work.

    [wp_rss_retriever url=”http://www.news.gov.hk/tc/common/html/ticker.rss.xml” items=”30″ excerpt=”20″ read_more=”true” credits=”true” new_window=”true” thumbnail=”150″ cache=”0″]

    This is a sample, the feed is in traditional Chinese. I made “excerpt=20” but the output doesn’t seem just 20.

    Thanks.

    By the way, thanks for the good work. Despite of the small bug, I tried several other most popular rss feeders and yours is the only one fits my requirements.

    Thank you.

    Plugin Author Travis

    (@tjtaylor)

    What language is set in your WordPress general settings? Is it Chinese Simplified?

    Plugin Author Travis

    (@tjtaylor)

    Hello,

    The plugin has been updated to fix this issue in version 1.3.1. You must have your language set to Chinese in WordPress general settings for it to work properly.

    Thanks for prompt response.

    1. We use both English and Traditional Chinese on this site, and we tried both English and Traditional Chinese.
    2. We upgraded to v1.3.1.
    3. Outcome is now worse than before, no feed came in and shown with the same short code.

    Plugin Author Travis

    (@tjtaylor)

    For some reason the quotes you posted in your shortcode do not all seem to be the same unicode. Try copying this shortcode:

    [wp_rss_retriever url="http://www.news.gov.hk/tc/common/html/ticker.rss.xml" items="30" excerpt="20" read_more="true" credits="true" new_window="true" thumbnail="150" cache="0"]

    Here’s a working demo of your feed using v1.3.1: http://demo.thememason.com/rss/rss-test-2/

    Plugin Author Travis

    (@tjtaylor)

    It’s also possible that with the cache disabled their server had gotten several requests from yours and possibly auto-blocked your servers IP. I would recommend enabling the cache and wait to see if your server IP becomes unblocked.

    Awesome! It works now! Thank you.

    One other suggestion, if you can enable an option to let us choose font-size for feed titles and font-size for excerpt contents, which will be even better.

    Thanks again.

    Plugin Author Travis

    (@tjtaylor)

    No problem.

    You can control the font-size for titles and content via “Additional CSS” in the built-in WordPress customizer.

    Example:

    .wp_rss_retriever_title {
    font-size: 2em;
    }
    
    .wp_rss_retriever_container {
    font-size: 1.2em;
    }
Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this review.