Support » Fixing WordPress » General category bug

  • Resolved alannie

    (@alannie)


    I tried to remove the general category.
    1. I changed the settings to use some other category as the default.
    2. I deleted the general category.

    All of my categories no longer appeared listed in the admin area.

    I restored my database from the backup. The categories reappeared.

    I followed the same steps to try again. Same result…categories no longer listed in admin area. Had to restore again from backup.

    Is there some other way to remove general without that happening?

Viewing 6 replies - 1 through 6 (of 6 total)
  • esmi

    (@esmi)

    Forum Moderator

    Did you transfer your posts to your new default category before deleting the old one?

    Did you asign your post to another category before deleting the default category? Posts MUST belong to a category.
    Edit: sorry esmi, you were faster (again) 😉

    I deleted all of the posts in the category first.
    Just tried it again..same result.

    esmi

    (@esmi)

    Forum Moderator

    How exactly are you changing the default category and the deleting the unwanted category? I simply cannot replicate your problem.

    Went to Settings..Writing and changed the default Category.
    Went to Categories…pointed to General then deleted it.

    There is one other thing that I thought of. I have a plugin installed called Restrict Categories. While the plugin works as described, there is a bug that I found…with the plugin activated, programs such as Blogpad cannot read the pages. Deactivate the plugin and pages can be read/imported. I wonder if that plugin is causing this issue as well. Will deactivate it and see if it makes a difference.

    RESOLVED! The plugin Restrict Categories caused the issue. When I deactivated the plugin, I was able to delete the general category without a problem.
    So..while the Restrict Categories plugin works as advertised, there are two issues with it that I have found.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘General category bug’ is closed to new replies.