Support » Fixing WordPress » General bugginess-possible avanced-cache.php error

  • eddiscsportsadmin

    (@eddiscsportsadmin)


    Having a problem with my website, widgets are not displaying properly and general bugginess. I went to deactivate plugins to see if I had some sort of conflict and I noticed I had advanced-cache.php listed in my drop-in plugins and it was not there before. I searched online for a solution and based on reading deleted it with file manager from wp-content/ but this did not solve the problem. I should add I’m using a sydney theme with siteorigin pagebuilder and wp fasted cache and autooptimize and cloudflare.
    Any help would be appreciated.
    Thanks,

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Well, since you’ve clobbered part of any cache plugin you might have been running you’ll probably want to disable any cache plugin if it didn’t disable itself already.

    I see the script for CloudFlare twice in that page you are having trouble with so I’m wondering if that might have broken something. I’d turn off CloudFlare’s proxy by going there and shutting down that from the CloudFlare DNS panel. Just turn off the ‘cloud’ icon from orange to gray. That will prevent CloudFlare from serving up anything broken from your site they might have in their cache.

    If you have the CloudFlare plugin you’ll probably want to disable that also. If you have the CloudFlare provided SSL turned on for your ‘origin’ server (your actual web host) you might need to fix that but if you are using CloudFlare by itself as the secure endpoint then it should still work without the ‘https’.

    I’d also kill the ‘Auto Optimize’ plugin for a bit. That might be munging that js code somehow.

    Was someone editing the theme or something? Because the home page is broke but the ‘about us’ page looks to be running just fine. I didn’t look at the rest.

    Let us know how that goes. It might be best to reload your current theme from your last good backup if you can if the above steps doesn’t fix things for you.

    eddiscsportsadmin

    (@eddiscsportsadmin)

    Thanks for the responce.
    Per your instructions I changed the dns clouds to gray, i deactivated the cloudflare plugin, the wp fastest cache plugin, and the autooptimize plugin. No one was editing the theme but I was working on a page with max mega menu plugin “https://www.eddiscsports.org/about-us/company-communications-and-marketing/” It is really odd what is affected and what is not the home page is the only page completely trashed but there are minor glitches on several other pages including the page I was working on. I should also add that I am running a child theme of sydney. I switched my theme to 2019 and then deleted and reinstalled sydney and then switched to child. Switching to Sydney without child seemed to fix alot of the problems but not all going back to child the original problems remain. I also reinstalled wordpress just to be certain.

    I’m starting to suspect that Mega Menu plugin because of its ability to have some CSS of its own. That and the ability to put widgets into the menu worries me.

    Why don’t you disable that plugin and see what happens?

    eddiscsportsadmin

    (@eddiscsportsadmin)

    I disabled max mega menu, which obviously changed the menu structure, but didn’t fix any of the layout issues.
    Thanks once again for the help, i know this is all a pain in the butt.

    Optimizing Matters

    (@optimizingmatters)

    for future reference; you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    hope this helps debugging,
    frank (ao dev)

    eddiscsportsadmin

    (@eddiscsportsadmin)

    thanks for the tip. Any other thoughts on fixing the site, ive run out of ideas and beyond my expertize

    Optimizing Matters

    (@optimizingmatters)

    well, given

    Switching to Sydney without child seemed to fix alot of the problems but not all going back to child the original problems remain.

    some/ most of your issues come from the child theme, if you developed that yourself try undoing your changes and see which one(s) caused the problems OR start again from scratch?

    eddiscsportsadmin

    (@eddiscsportsadmin)

    there are only 4 files in the child theme and its easy enough to scroll through them, i can’t imagine its anything in them.
    Also theis morning the advanced cache.php plug in is back in the drop in with the following message:
    “advanced caching plugin. Inactive: Requires define(‘WP_CACHE’, true); in wp-config.php file.”
    Again there have not been drop in plugins before.

    eddiscsportsadmin

    (@eddiscsportsadmin)

    Update: I manually removed each of the files from the child theme and it did not fix my issues, the homepage corruption exists and a few bugs on other pages.

    eddiscsportsadmin

    (@eddiscsportsadmin)

    So I managed to fix my site. When I was manually going through the child theme I realized that its functions.php was missing, restoring that fixed the site, still not sure how it was deleted but as its restored i will count my blessings
    Thanks to all that assisted me with my troubles

    Optimizing Matters

    (@optimizingmatters)

    great job eddiscsportsadmin, happy things are OK now 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.