WordPress.org

Forums

Gecka Submenu
[resolved] Gecka Submenu uses call-time pass-by-reference, which throws fatal errors (6 posts)

  1. cbj4074
    Member
    Posted 3 years ago #

    Call-time pass-by-reference has been deprecated since PHP 5.3, and has been removed from PHP 5.4. In other words, this plug-in throws fatal errors in several places when used with PHP >= 5.4.

    The fix is rather simple: remove the leading ampersands ("&") from the function calls (not the definitions).

    http://wordpress.org/extend/plugins/gecka-submenu/

  2. PurpleEdge
    Member
    Posted 2 years ago #

    Tried the fix, can activate it, but it doesn't work! I can't get anything into the menu, it just remains blank.

    This issue should have been fixed by now, especially since they have a pro version!

  3. 1-krn
    Member
    Posted 2 years ago #

    We experienced the same problem last week on our website, quite possibly due to our host updating their PHP from version 5.3.10 to 5.4.9.

    As a temporary measure, our web development company had to deactivate the Gecka Submenu plugin from our site-- so currently our site is without the sidebar menus it is supposed to have--
    http://www.inplace.com

    Will this plugin ever get fixed to work with later PHP versions?

  4. Mark
    Member
    Posted 2 years ago #

    I can confirm this same problem still exists on WordPress 3.5 and php 5.4. For a plugin that is advertised as requiring php 5, this is a bit surprising.

  5. Gecka
    Member
    Plugin Author

    Posted 2 years ago #

    Should be solved in 0.7beta4.

  6. Mark
    Member
    Posted 2 years ago #

    I can confirm it is solved in the latest version. Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Gecka Submenu
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.