Support » Fixing WordPress » GDPR notice in WP 4.9.6

  • Pádraig Ó Beirn

    (@padraigbeirne)


    Hi guys,

    I’ve updated to WordPress 4.9.6 on my live, mirror and localhost wamp site. Everything worked fine except for this niggle on my mirror development site…

    The notice ‘Are you GDPR compliant?’ keeps re-appearing no matter how many times I dismiss it. The site is hosted on Apache but uses a dummy domain that only I can access having edited my pc vhosts file. As I say, my live site and localhost are fine – the notice stays dismissed. Any ideas?

    Thanks in advance. 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Steven Stern

    (@sterndata)

    Support Team Volunteer

    Where is that notice appearing?

    Pádraig Ó Beirn

    (@padraigbeirne)

    The notification appears at the top of each page in the admin panel. If I go to the dashboard, for example, it appears and I can dismiss it. However, when I visit any other area of the admin it re-appears. It contains a button to click in order to ‘Check the GDPR requirements to make sure you comply.’ If I click the button I get ‘Sorry you are not allowed to access this page.’ even though I am logged in as the admin.

    On my live site and wamp install the notification also appears after updating to 4.9.6 but does not re-appear after it’s dismissed.

    Moderator Steven Stern

    (@sterndata)

    Support Team Volunteer

    That doesn’t seem to be a core message — at least, I cannot find the string on any of my sites.

    Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    See http://www.wpbeginner.com/plugins/how-to-deactivate-all-plugins-when-not-able-to-access-wp-admin/

    Pádraig Ó Beirn

    (@padraigbeirne)

    Thanks Steve,

    That did it! I had updated a few plugins along with 4.9.6 and assumed, because GDPR was a large part of the 4.9.6 update, that the message was a core notification. The culprit is Tribulant newsletter. I usually follow the steps you outlined above when troubleshooting but didn’t this time because the WP update was GDPR focused. Thanks for your time and prompt response. I really appreciate it. I’ll contact the plugin authors and let them know.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘GDPR notice in WP 4.9.6’ is closed to new replies.