WordPress.org

Forums

Google Doc Embedder
[resolved] GDE fails with "Ubuntu one" cloud storage URL (4 posts)

  1. kcrao.bsnl@gmail.com
    Member
    Posted 2 years ago #

    Hi,

    I'm using https://one.ubuntu.com as my cloud storage to hyper-link all my documents. GDE fails to load the documents when using url's from UbuntuONE

    [gview file="http://ubuntuone.com/1YNlvxVvHowzunowk9VS7d"]

    but, GDE Works perfectly when the url is something like below (url ending with filename)

    [gview file="products.secureserver.net/guides/wordpressgsg.pdf"]

    Can we resolve this?

    Thanks in advance, jim

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Plugin Author

    Posted 2 years ago #

    Hi there,

    The plugin fails to load because it is expecting the file to end in one of the supported file extensions (in this case ".pdf"). It appears UbuntuONE is using some other kind of code to represent the true name of the document. I believe this will still work in GDE (though admittedly I have not tried it) if you turn off the plugin's own error checking.

    To do this in GDE 2.4.x -

    GDE Settings > Advanced Options/Plugin Behavior > check "Disable internal error checking"

    To do this in GDE 2.5.x -

    GDE Settings > Advanced tab > uncheck "Check for errors before loading viewer"

    Hope this helps.

    Kevin

  3. kcrao.bsnl@gmail.com
    Member
    Posted 2 years ago #

    thanks kevin, for your fastest reply, It's working :)

    But need a small change, the below code

    [gview file="http://ubuntuone.com/1YNlvxVvHowzunowk9VS7d"]

    results in displaying file download link with hash instead of its file name.

    Download ( 1YNlvxVvHowzunowk9VS7d, , 151KB)

    how can i change the download file name?

  4. k3davis
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry for missing your reply to this message. What string are you using to customize the download link? I assume one of the options you're using is filename, which GDE isn't aware of in this case. You will probably want to remove that portion.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic