Support » Plugin: Simple Calendar - Google Calendar Plugin » GCE 2.1.0 now updated for GCal API v3

  • ResolvedPlugin Contributor Phil Derksen

    (@pderksen)


    Great news. We’re pretty darn sure your Google calendar displays will work once again.

    Nick and I have been working on the switch to the new Google Calendar API (version 3), and after a bunch of tweaks and testing we believe it’s now good to go.

    Please update your GCal Events plugin to 2.1.0 (or higher) and let us know in the forums if it’s still not working.

    Google basically requires an API key for all requests now. By default the WordPress plugin now uses a shared public API key we generated.

    Our request limit shared among all users is currently 500,000 requests per day and 5 requests per second. We applied for more today, but we’ll have to wait to hear back from Google if we’re allowed na increase.

    At 330,000+ plugin downloads we’re not sure if this is sufficient or not yet for everyone. But we do know that the caching provided in our plugin helps reduce the number of requests.

    If you’re concerned about this quota set for all plugin users, you do have the option of generating and using your own GCal API key across your sites. More info and instructions are found on the General Settings page after you update.

    Sorry again for the downtime the last couple days. We’ll do our best to tackle these issues a little more in advance in the future.

    https://wordpress.org/plugins/google-calendar-events/

Viewing 15 replies - 106 through 120 (of 123 total)
  • Thanks for all your help – Authors – if you can look into why (jquery-qtip.js) is failing with Version 2.1.4 – prev / next buttons and pop outs are not working.

    Here’s an interesting bug. I’ll describe how I got it.

    I’m running version 2.1.3 (because I hadn’t realized there was a new version — I will try the new one later and see if I get the same strange behavior).

    My feed uses the Event Builder as follows:
    Code:
    [if-not-all-day] [start-time] [/if-not-all-day] <span class="gce-list-event"> [event-title] </span>

    Feed settings:
    Expand recurring events? Yes
    Date format: l, M j
    Time format: g:ia
    Cache duration: blank
    display mode: grid
    number of events per page: 9 events
    display staft date offset: 0 days ahead
    minimum feed start date: 1 months back
    maximum feed end date: 2 years forward

    Here’s the code in my page:
    [gcal id="1292" display="grouped-list"]

    The first event that gets displayed happens to be an all-day event.

    The weird result: the first event listed doesn’t have a date associated with it! (Other all-day events are fine.)

    I can solve this problem in two ways — by giving that first event a start time, or by changing the code in the page to the following:
    [gcal id="1292" display="grouped-list" interval="days" interval_count="8"]

    Note that the following does not solve the problem:
    [gcal id="1292" display="grouped-list" interval="events" interval_count="8"]

    Thanks to the developers for making very clear instructions for setting up the API.

    Developers, could you please post more examples? And with each example, it would be helpful if you could show what the results look like. Thanks!

    I updated to 2.1.4 and the situation seems to be the same as I described.

    By the way, all-day events don’t line up with events that have a start time. The all-day events start about one character to the right.

    Oops, I found out that all the event titles have a slight extra indentation. This is noticeable if you allow the event title to be all alone on a line (without, for example, a preceding word or phrase, such as “Event: “).

    An apparently unrelated problem: I can’t get the Past Events to go back far enough in time. Here is the google calendar:
    Here is the WordPress page that’s showing too few events from the past: http://www.ithacasepta.org/test-plugin/

    My settings and code:

    <h4>Upcoming Events-Full</h4>
    [gcal id="1292" display="grouped-list" interval="days" interval_count="19"]
    <h4>Test Past Events-Full</h4>
    [gcal id="1311" display="grouped-list" order="desc" interval="days" interval_count="800" ]

    Here is the Google calendar in question: https://www.google.com/calendar/embed?src=pdm5jvuqake8kl2bj1v4ec7ob8%40group.calendar.google.com&ctz=America/New_York

    I’d like to go back at least a year and a half. There aren’t a lot of events on this calendar.

    Sorry, I forgot to show the particulars for feed 1311.

    <span class="gce-list-event"> [event-title] </span>
    <div>[if-not-all-day] Time: [start-time] - [end-time] [/if-not-all-day] </div>
    
    [if-location]
    <div>Location: [location]</div>
    [/if-location] [if-description]
    <div>Description: [description]</div>
    [/if-description]

    Date format: l, M j, Y
    Time format: g:ia
    Cache duration: 1 (for debugging)
    Display mode: Grid
    Number events per page: 30 Events
    Display start date offset: 180 days back
    minimum feed start date: 3 years back
    Max feed end date: 0- days forward

    Progress. I am using the same feed settings and code as before, except I changed “Display start date offset” to 600. The shortcode on the page is now as follows:

    <h4>Upcoming Events-Full</h4>
    [gcal id="1292" display="grouped-list" interval="days" interval_count="19"]
    <h4>Test Past Events-Full</h4>
    [gcal id="1311" display="grouped-list" order="desc" ]

    The result is now almost what is needed. The only problem is that the results page displays an all day event for today in the Past Events list. I would rather that it only appear in the Coming Events list. I haven’t found a way to adjust the settings to get today’s event eliminated from the descending list.

    My calendar feed was not displaying. I generated an API key, verified the correct calendar ID was being used, etc. The problem ended up being that the “Minimum Feed Start Date” and “Maximum Feed End Date” had both been reset to 0 days, presumably on updating the plugin to the latest version.

    I hope this is just an isolated problem with migrating settings to the new Gcal API. Devs, please check and make sure those settings have sane defaults (and THANK YOU for your work on this plugin).

    Will this Google API issue be resolved for those running version 0.7.3.1?
    I appreciate there has been a great update but the newest version doesn’t offer the functionality I require for my website (The ability to show activities taking place ‘today’, ‘tomorrow’, etc) and as such my “carers resource” has now been rendered useless.

    Thanks

    ignore previous post – I have finally managed to get the newest version working

    I haven’t seen this in the previous questions:
    I have completely reconstructed the GCal feed page, and the widget details, and would like to see a list. However, all I see is a grid:
    And I don’t really know where I might change the short code. Above some said to change it in the page, but where would that be?? Thanks for any help.
    My site showing the grid instead of list, but I won’t be leaving it up that way very long.
    http://www.becvote.org/wordpress/

    Thanks for help.

    I made sure the details in feed and in the widget are the same, as to number of events to show, etc.
    http://www.becvote.org/wordpress/

    Hello — google calendar still not appearing after update this morning to newest version of plugin — this is the message that shows on the page: Some data was retrieved, but could not be parsed successfully. Please ensure your feed settings are correct.

    Here is a link to the page: http://portsmouthhistory.org/calendar-2/

    How do I ensure my feed settings are correct?

    thank you!

    Okay — just updated the feed setting, and now the calendar is working! Thank you.

    I don’t see items on my calendar anymore.
    I have added an API key as you suggested.
    I just cannot ad a user-id as you mention it.

    In my case (and yes I have set it to public) is only get as an id, my gmail-adres.

    any idea?

    Regards,

    Peter

Viewing 15 replies - 106 through 120 (of 123 total)
  • The topic ‘GCE 2.1.0 now updated for GCal API v3’ is closed to new replies.