Support » Theme: Gazette » Gazette theme – featured posts not showing images

  • Resolved matthewbarr

    (@matthewbarr)


    Hi there,

    Any ideas why the Gazette theme isn’t showing images in the ‘featured’ posts at the top? Our site should look like the screenshot on the theme page (https://wordpress.com/theme/gazette) but we see the posts and accompanying text – just no image/video.

    I notice that the path to the image in the generated code is undefined:

    <a class="post-thumbnail" href="https://ada.scot/2020/08/08/glasgow-women-in-computing-science/" style="background-image: url(&quot;undefined&quot;);"></a>

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Make sure you added the featured tag.

    Otherwise, we will need to see the site to offer any help.

    I’m having the same issue on my blog https://westerngeomancy.org/blog/.

    Featured images used to display perfectly, so I know that I had them set up correctly, but now I just get black squares.

    The images do show if I go into the customiser, but I’m stumped as to why they don’t show when published.

    I’ve tried in Firefox and Chrome.

    I see the images on your site, @westerngeomancy, though I do see black squares before the images load.

    Hmmm… interesting. I thought it must be an adblocker or some other privacy plugin on my browser, but I just get black squares in Firefox, Chrome, and Edge. Weird.

    Must be some other setting on my PC – maybe firewall or virus checker? I’ll keep looking.

    All the theme images seem a little slow to load. I’ve tried smushing them down but don’t know what else I can do about it.

    Jerry B

    (@jerrysarcastic)

    Howdy @westerngeomanc when I visit your site the images seem to load pretty quickly for me, and I do not see the “black squares” issue.

    Generally speaking if the issue is happening for you across all browsers then it is not likely to be an extension issue, but an issue with your network (speed, stability, firewall, etc.) which seems to be the case here.

    A quick way to rule that out is to visit your site in a “private session” or “incognito window” which will skip your cache, cookies, and extensions.

    If you see the same problem even when visiting your site incognito, I do think it makes sense to take a closer look at your network conditions or any possibility of a firewall. For example if you have this issue on your home wifi, what if you visit your site from some other network, like a local cafe, work, library, etc. and see if you can narrow down to if the issue is with your home network specifically.

    Hope this helps

    Hi @westerngeomancy,

    Is this happening with the images in the featured post grid at the very top of the site?

    If it is, I think can see the problem occurring on your site.

    It looks like a plugin is trying to speed up the site by base64 encoding the images, but that is inadvertently preventing them from being loaded as background images in the grid.

    (Screenshot for the Automattic employees – https://cloudup.com/coMuc7ZAHAM)

    Here are some steps to troubleshoot what’s causing the problem:

    1. Please delete the cache in WP Fastest Cache, then try temporarily disabling the plugin.

    2. If the issue persists when WP Fastest Cache is disabled, try disabling image lazy loading in Jetpack → Settings → Performance.

    3. If the issue still persists, try disabling Site Accelerator in Jetpack → Settings→ Performance.

    If the issue persists when all of those steps are done, please try temporarily disabling all plugins, except Jetpack, to check for a conflict.

    Hi Gary.

    I tried all of those ideas, and after disabling everything, I eventually traced it to the Smush plugin. Seems to be their beta ‘lazy load’ setting that’s causing the problem. I’ve turned it off for that particular page and everything seems fine now.

    Many thanks!

    You’re welcome, glad I could help 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.