Support » Plugin: Easy WP SMTP » Gateway timeout

  • I entered my SMTP server (which I tried and works with same setting). when I went to “test” tab, upon submission I get gateway timeout.

    I tried another plugin and same issue. what am I missing?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, have you contacted your host about this issue? You might also like to check the server log files. They might reveal why the timeout is happening.

    Kind regards

    Thread Starter Hadi

    (@v_r_boy)

    there is nothing in logs. I turned on debug to see more.

    I see nothing obvious in logs

    POST /wp-admin/admin-ajax.php HTTP/1.1" 200 58 "http://blog.kamva.ir/wp-admin/options-general.php?page=swpsmtp_settings" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
    2018/05/14 07:30:15 [error] 137#0: *11 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 100.100.50.1, server: localhost, request: "POST /wp-admin/options-general.php?page=swpsmtp_settings HTTP/1.1", upstream: "fastcgi://unix:/tmp/heroku.fcgi.8080.sock", host: "blog.kamva.ir", referrer: "http://blog.kamva.ir/wp-admin/options-general.php?page=swpsmtp_settings"
    100.100.50.1 - - [14/May/2018:07:30:15 +0000] "POST /wp-admin/options-general.php?page=swpsmtp_settings HTTP/1.1" 504 578 "http://blog.kamva.ir/wp-admin/options-general.php?page=swpsmtp_settings" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
    100.100.50.1 - - [14/May/2018:07:30:17 +0000] "GET /favicon.ico HTTP/1.1" 200 5 "http://blog.kamva.ir/wp-admin/options-general.php?page=swpsmtp_settings" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
    
    Thread Starter Hadi

    (@v_r_boy)

    just tried on a totally different host, same issue.

    Thread Starter Hadi

    (@v_r_boy)

    I have checked my username password. there is no % in them. I use no TLS and the port is 25

    however, my username has / in it. there is nothing I can do about that. I just tested the SMTP server inside a test PHP application I wrote and it works.

    CLIENT -> SERVER: EHLO localhost
    CLIENT -> SERVER: AUTH CRAM-MD5
    CLIENT -> SERVER: a2FtdmEvaGV0em5lci0wMSA0Zjg4NzA4NjZiNjMwM2NhYWNmOGZmOWRkN2Y2OWFmYw==
    SMTP ERROR: Username command failed: 535 Denied
    SMTP Error: Could not authenticate.CLIENT -> SERVER: QUIT
    SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
    • This reply was modified 3 years, 8 months ago by Hadi.
    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hi Hadi.

    Please refer to this thread https://wordpress.org/support/topic/could-not-connect-to-smtp-host-email-on-one-host-website-on-another/

    We will release an update that addresses this issue. Meanwhile, you can use testing version provided in that thread. It will get updated to stable version once its released, so there will be no need to delete it and install again.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Gateway timeout’ is closed to new replies.