WordPress.org

Support

delete posts

Viewing 15 replies - 1 through 15 (of 20 total)
  • Method No. 1:

    Go to Dashboard –> Manage. You should end up on your Manage Posts page.

    Find the post you want to delete.

    Mark the box to the immediate left of the post.

    Hit the Delete button above it.

    Method No. 2:

    Go to Dashboard –> Manage. You should end up on your Manage Posts page.

    Find the post you want to delete and click on it. Now you should be on the edit post page.

    Look for the link “Delete post” under your write screen. If you can’t find it, do a find search from your browser (like CTRL-F)

    Rosie,

    since upgrading to v2.5, I have not been able to delete posts. On pressing the submit button I get: HTTP 500 Internal Server Error!

    Why?

    How can I get full functionality back?

    I would start by deactivating all your plugins and see if you can edit/delete pages afterward.

    If you can, then reactivate one plugin and test your page editing/deleting ability.

    Keep on doing this until you figure out which plugin is causing the problem.

    If the problem persists even after you deactivate all your plugins, then somebody else might be able to chime in here with an idea, but plugin incompatibility is a very common problem.

    Good luck! I know this can be frustrating.

    Rosie,

    Many thanks for reasponding.

    I did this exercise already to no avail. But will do it again.

    I do hope it works this time round.

    Robert, if your site still doesn’t work properly after testing your plugins, you might try uploading the new 2.5.1 upgrade. There are several bug fixes in it.

    Also, sometimes problems are caused because the initial upgrade wasn’t fully loaded somehow; a fresh set of files might fix it.

    Rosie,

    Nope. No change. I did the plugins bit and the upgrade and I still cannot see images in the blog even in preview mode. Nor can I navigate from Manage to Dashboard.

    Here is the code I get when navigating back to Dashboard:
    Warning: main(./wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/iscatte/public_html/wp-content/plugins/index.php on line 4

    Warning: main(./wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/iscatte/public_html/wp-content/plugins/index.php on line 4

    Warning: main(./wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/iscatte/public_html/wp-content/plugins/index.php on line 4

    Fatal error: main() [function.require]: Failed opening required ‘./wp-blog-header.php’ (include_path=’.:/usr/php4/lib/php:/usr/local/php4/lib/php’) in /home/iscatte/public_html/wp-content/plugins/index.php on line 4

    I cannot make sense of it.

    You?

    Regards

    RB

    Just uploaded 2.5.1 again and it still shows as 2.5 at the footer!

    Okay, Robert, I did a search for that error message and found the thread you started here.

    Am I to understand that you were having a problem BEFORE you upgraded to 2.5? That would mean it is not an upgrade issue.

    That error message includes the word “plugins”, which MIGHT mean this is is a plugin error.

    Before your site began acting up, had you added any new plugins? And did you add this message to your wp-content directory?

    I really think it’s a plugin error, either something you did, or something (perhaps) somebody else did.

    Your plugin directory is messed up, too. You (or somebody) added an index.php file that is messing it up on line 4.

    Erase the whole index.php file and see if that fixes your problem.

    Rosie,

    See this post. I think it says it all about release 2.5.1

    No wonder!

    Nope.

    This is not an upgrade problem. As you indicated in your other thread, you had problems BEFORE you upgraded, so the thread you just linked to does not really apply to you.

    Did you check that index.php file in your plugins directory? If you delete it, there’s an excellent chance you’ll get rid of those error messages.

    You’ve also got a malformed index.php file in your themes directory. Delete that one, too.

    Unfortunate, I think that is update issue.

    I have the same problem after 2.5.1. By deleting I receive error, something like “deleting error, deleting impossible now” but after refreshing the page deleted post is deleted exactly and stop to be presented on the list… any idea?

    Mareksy, I believe Robert’s problem with deleting posts is unrelated to his upgrade, as it was happening before he upgraded.

    His problem in not being able to upgrade to 2.5.1 kind of confirms it for me: I think he may have been hacked before he did his upgrade.

    I mean, I could be wrong, but a lot of people running pre-2.5 versions were hacked, upgraded their sites and took the hacked files along for the ride.

    As for your problem, maeksy, it would help to know what the message error says. If you search for the error message in the forum, you might find your answer very quickly.

    OK Rosie – UR answer is: blank screen with the sentence: “error in deleting…” Refresh gives the same.
    Return by back button gives old page of manage with deleted message still existed. Refresh now gives manage page without it.

    I searched for answer – any found is people have the same problem and no idea how to finish that, maybe U will help?

    Have you tried trying to delete those posts in different browsers as suggested in this thread?

    I can’t find any threads that offer a solution. You guys may have discovered a bug — or it may be something very simple we’ve all overlooked.

    There is another option for help: the IRC channel. I haven’t used it myself yet, but it’s worth a try.

    If you do ask for help there, and you find a solution, please remember to come back and post it here.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘delete posts’ is closed to new replies.