Support » Plugin: WP SMS » Gateway Parameters for ExpertTexting Incorrect

  • Resolved rwcapodi

    (@rwcapodi)


    In version 5.4, the last version that works with experttexting, the call to the gateway looks like this:

    foreach ( $this->to as $to ) {
    $response = wp_remote_get( $this->wsdl_link . “json/Message/Send?username=” . $this->username . “&password=” . $this->password . “&api_key=” . $this->has_key . “&from=” . $this->from . “&to=” . $to . “&text=” . $text . “&type=” . $type, array( ‘timeout’ => 30 ) );
    }

    Issue: In your versions following 5.4, the call to ExpertTexting is a messed up… in the file class-wpsms-gateway-experttexting.php, line 74 looks like:

    foreach ($this->to as $to) {
    $response = wp_remote_get($this->wsdl_link . “json/Message/Send?username=” . $this->username . “&api_key=” . $this->has_key . “&from=” . “&api_secret=” . $this->password . $this->from . “&to=” . $to . “&text=” . $text . “&type=” . $type, array(‘timeout’ => 30));
    }

    Remediation: I replace the code (lines 74-76) with version 5.4 over 5.5, afterwards, my authentication issue (invalid credentials) with ExperTexting.com resolved itself.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Mostafa Soufi

    (@mostafas1990)

    Hi,

    Thank you for reporting the issue, I’ve just fixed the issue in the development version which will be released the new version soon.

    https://github.com/veronalabs/wp-sms/commit/742f5896b985828f09e12c74f5fb4a2e7fb4c6b1

    Best

    Thread Starter rwcapodi

    (@rwcapodi)

    Just installed your “fix” 5.5.1 this morning, and sadly, it is not working… as the parameters your passing to ExpertTextings API remain in conflict with what their API is expecting…

    The solution (provided above), if you wish to employ it, taken from version 5.4, is shown below…

    `foreach ($this->to as $to) {
    /*5_4*/ $response = wp_remote_get( $this->wsdl_link . “json/Message/Send?username=” . $this->username . “&password=” . $this->password . “&api_key=” . $this->has_key . “&from=” . $this->from . “&to=” . $to . “&text=” . $text . “&type=” . $type, array( ‘timeout’ => 30 ) );

    • This reply was modified 5 months, 1 week ago by rwcapodi.
    • This reply was modified 5 months, 1 week ago by rwcapodi.
    • This reply was modified 5 months, 1 week ago by rwcapodi.
    Plugin Author Mostafa Soufi

    (@mostafas1990)

    BTW did you configure the gateway correctly? because in the document it has mentioned that the api_secret is required. anyway, I’ve just updated the fields’ labels there and a tweak improvement, hope would be clear and fix the issue

    https://github.com/veronalabs/wp-sms/commit/915efceeec6e19b66c34bb4febe25ba15c3e09f5

    Thread Starter rwcapodi

    (@rwcapodi)

    Yes, my configuration is correct… and I am using the WP_SMS UI when testing…

    When I updated WP-SMS to v5.5, the call to the gateway ExpertTexting failed with an authentication error. I reached out to ExperTexting support and with their assistance, resolved the issue by discovering that WP-SMS v5.5 parameter list had to be modified to what was reflected in v5.4 – applying these changes in v5.5 resolved the issue.

    The call to the ExpertTexting gateway will work in v5.5.1 once you make the code changes to reflect what was originally in v5.4.

    Going forward, may I suggest you reach out to ExpertTexting support.

    Plugin Author Mostafa Soufi

    (@mostafas1990)

    We’ll reach out to them as soon as possible. Thanks for explaining.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.