Support » Plugin: WP Cassify » Gateway Mode and Single Sign Out

  • Resolved dedotombo

    (@dedotombo)


    If someone’s interested I’ve hacked the plugin a little bit in order to easily perform automatic login (gateway mode) and single sign out.
    I’ve also loosened an interface constraint on the admin panel because my ruby cas implementation didn’t use “p3/” in serviceValidate url.

    I hope that the developer could take a look at my code because it’s not perfect, but it works.

Viewing 5 replies - 1 through 5 (of 5 total)
  • scooterlord

    (@scooterlord)

    Hello there. I implemented the plugin and was looking for single sign out.. imagine my surprise I just saw this. Would you care sharing your code?

    NS

    dedotombo

    (@dedotombo)

    As I said, it’s a little bit hackish but I hope that sharing the code could improve the solution. The single sign out function should be solid and secure, I ported it from the phpCAS library.

    Modified admin/admin-menu.php: https://pastebin.com/bMzDrPzB
    Modified classes/wp_cassify_plugin.php: https://pastebin.com/QbAgdeAW

    That’s it, once uploaded two new checkbox (“Enable gateway mode” and “Enable Single Sign Out”) should appear in WP Cassify admin menu.
    Maybe you’ll have to modify the service validate servlet to “p3/serviceValidate” (if it isn’t already configured this way), “p3/” is not added automatically anymore in my version.

    dedotombo

    (@dedotombo)

    I have modified the pastbins.

    Automatic login through gateway mode does not seem to work anymore (not even modifying the theme files as suggested by the developer) so I dropped it.

    I have improved the Single Sign Out code that is much less hackish now, I’d say production ready.

    Same links, different code.

    Modified admin/admin-menu.php: https://pastebin.com/bMzDrPzB
    Modified classes/wp_cassify_plugin.php: https://pastebin.com/QbAgdeAW

    dedotombo

    (@dedotombo)

    Pastebins modified again.

    I improved the single sign out code, fixed a plugin bug and reimplemented automatic login, now everything should work fine.

    Same links, different code.

    Modified admin/admin-menu.php: https://pastebin.com/bMzDrPzB
    Modified classes/wp_cassify_plugin.php: https://pastebin.com/QbAgdeAW

    scooterlord

    (@scooterlord)

    Thanks for this! Good thing I didn’t rush into it (by accident!). Will try to check soon and report back – my priorities have changed :/

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Gateway Mode and Single Sign Out’ is closed to new replies.