Support » Plugin: Postman SMTP Mailer/Email Log » Gateway Error, Invalid Envelope from Email Address

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jason Hendriks

    (@jasonhendriks)

    @michaelnorth sorry you’re having a problem with the plugin. Thanks for the screenshots, they’re very helpful.

    Is this the same environment as the first time you used Postman? The gateway error means your web host killed the Postman ajax request (for taking too long) before Postman responded to your browser. Things may or may not work after this kind of “hijack” :-/ It looks like for you, things did not work.

    Postman Transport Status (Configured|Ready|Connected): No | No | n/a
    Postman Sender Domain (Envelope|Message):
    Postman Transport URI:

    The Postman configuration created by the Wizard was not saved. I recommend using Advanced Configuration to input your settings manually. Looks like the Wizard is out for you.

    On the Account tab, you’ll want to use:

    • Transport: SMTP
    • Hostname: smtp.gmail.com
    • Port: 465
    • Security: SMTPS
    • Authentication: OAuth 2.0

    You’ll also need to input your Gmail email address into the two From Address fields on the Message tab.

    but mail will not send — “Invalid Envelope from email address xxxxx@saintjohns.school”.

    I think this error is a red herring. Postman is NOT sending mail according to the configuration you sent me, so this error must be from before when you had Postman at least partially configured.

    Out of curiosity – what web host are you using?

    Hi Jason,

    Thanks for the super-fast response 😉

    You’re exactly correct on that last point, the “invalid envelope” error was from my last attempt, after I had gone through the entire setup.

    Yes, this is the same hosting environment as my last project which worked great with Postman – it’s Siteground shared hosting plan. The difference is that this time, we are attempting to route mail through Gmail, instead of the Siteground mail server.

    I’ll try the advanced config now, and get back to you. Thanks!

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    You may want to let them know that sometimes HTTP requests take more than 30 seconds, but they probably won’t care 😉

    Make sure you run the Connectivity Test on smtp.gmail.com and make sure they haven’t blocked you from accessing that server.

    Hi Jason,

    I went through the entire setup process again, using your manual configuration settings, and newly-created credentials in the Console. Everything looks normal and saves properly, but I get exactly the same “invalid envelope” error. Cannot send.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Could you post the Session Transcript please from the Email Log.

    I uploaded the connectivity test: https://www.dropbox.com/s/r2o5ynde2govs2a/postman-10-10-2015-03.png?dl=0

    Updated diagnostics:

    OS: Linux serv01.m36.siteground.biz 2.6.32.59-sg3 #9 SMP Wed Sep 26 03:29:25 CDT 2012 x86_64
    HTTP User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36
    PHP: Linux 5.6.13 C
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=Yes
    WordPress: 4.3.1 en_US
    WordPress Theme: Total
    WordPress Plugins: ManageWP – Worker, Gravity Forms, AddFunc Head & Footer Code, BOXIT 2, Chrome Admin Menu Fix, Duplicator, Email Address Encoder, Give – Donation Plugin, Google Analytics by Yoast, Google Apps Login, Google Drive Embedder Premium, WPBakery Visual Composer, Last Modified Timestamp, Postman SMTP, Review Stream, Optimize Database after Deleting Revisions, Templatera, Wordfence Security, Yoast SEO, WP-SpamShield, WPFront User Role Editor Personal Pro
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email
    Postman: 1.6.24
    Postman Sender Domain (Envelope|Message): saintjohns.school | saintjohns.school
    Postman Prevent Message Sender Override (Email|Name): No | No
    Postman Transport URI: smtp:ssl:oauth2://smtp.gmail.com:465
    Postman Transport Status (Configured|Ready|Connected): Yes | Yes | Yes
    Postman Deliveries (Success|Fail): 0 | 0

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Interesting. Lots of errors from Siteground. Clearly they are blocking ports 25 and 587. The Gmail API might be your only option.

    Can you post the Session Transcript? From the Email Log.

    Huh, the post I just made here disappeared, trying again . . .

    Jason, I can’t get to any transcript, all links to transcript are grayed-out. But I did find this if it helps:

    From: Saint John’s Episcopal School <hello@saintjohns.school>
    To: michael@alta-publishing.com
    Date: 2015-10-10 09:22:13
    Subject: Postman SMTP Test (saintjohns.school)
    Delivery-URI: smtp:ssl:oauth2://smtp.gmail.com:465
    Content-Type: text/plain; charset = “UTF-8”
    Content-Transfer-Encoding: 8bit

    Hello!

    Sent by Postman 1.6.24 – https://wordpress.org/plugins/postman-smtp/

    Content-Type: text/html; charset=UTF-8
    Content-Transfer-Encoding: quoted-printable

    < !DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd”&gt;
    <html xmlns=”http://www.w3.org/1999/xhtml”&gt;
    <head>
    <meta http-equiv=”Content-Type” content=”text/html; charset=utf-8″ />
    <style type=”text/css” media=”all”>
    .wporg-notification .im {
    color: #888;
    } /* undo a GMail-inserted style */
    </style>
    </head>
    <body class=”wporg-notification”>
    <div style=”background: #e8f6fe; font-family: & quot; Helvetica Neue" , Helvetica ,Arial,sans-serif; font-size: 14px; color: #666; text-align: center; margin: 0; padding: 0″>
    <table border=”0″ cellspacing=”0″ cellpadding=”0″ bgcolor=”#e8f6fe” style=”background: #e8f6fe; width: 100%;”>
    <tbody>
    <tr>
    <td>
    <table border=”0″ cellspacing=”0″ cellpadding=”0″ align=”center” style=”padding: 0px; width: 100%;””>
    <tbody>
    <tr>
    <td>
    <div style=”max-width: 600px; height: 400px; margin: 0 auto; overflow: hidden;background-image:url(‘https://ps.w.org/postman-smtp/assets/email/poofytoo.png&#8217;);background-repeat: no-repeat;”>
    <div style=”margin:50px 0 0 300px; width:300px; font-size:2em;”>Hello! – 你好 – Bonjour! – नमस्ते – ¡Hola! – Olá – Привет! – 今日は</div>
    <div style=”text-align:right;font-size: 1.4em; color:black;margin:150px 0 0 200px;”>Sent by Postman 1.6.24

    <span style=”font-size: 0.8em”>https://wordpress.org/plugins/postman-smtp/</span>
    </div>
    </div>
    </td>
    </tr>
    </tbody>
    </table>

    <span style=”font-size:0.9em;color:#94c0dc;”>Image source: poofytoo.com – Used with permission</span>
    </td>
    </tr>
    </tbody>
    </table>
    </div></body>
    </html>

    Jason, I can’t get to the Session Transcript, the link is grayed-out wherever I look.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Ok, of course because this is a Postman error, not a Gmail error.

    I was able to reproduce your problem by using your email address on my own system. The error is generated by Zend_Mail, the mail library Postman uses. In more detail Zend is claiming:

    • ‘saintjohns.school’ appears to be a DNS hostname but cannot match TLD against known list
    • ‘saintjohns.school’ appears to be a local network name but local network names are not allowed

    According to dig, saintjohns.school is definitely a known TLD. My guess is Zend does not approve of the ‘.school’ domain.

    Here’s a new version of Postman that will allow you to disable email validation. You can find the new option in the Advanced Configuration on the Message tab.

    Hope that helps?

    Awesome Jason! Your solution worked perfectly 😉

    The list Zend uses has apparently has not been updated to include some new TLD’s including .school (released this summer).

    I trust you will add the “disable email validation” feature to new versions of Postman? (there are a lot of new TLDs coming)

    Thank you Jason, I appreciate your considered, fast response on this. Another 5-star review for Postman!

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    I will add this to 1.7 with probably an option to keep validation but remove domain checking.

    Amr Ali

    (@amr3li)

    Hello Everyone,
    TLD domains – SMTP emails not sent

    I had the same issue earlier today “Invalid Envelope from Email Address” and I am using the “SMTP” method not “Gmail API”, and my project site is on a TLD domain too.

    But after updating Postman SMTP plugin to version “1.6.25” and
    disabling Email validation the issue was fixed and now Emails are sent correctly.

    Thanks Jason for the brilliant work!

    michaelnorth

    (@michaelnorth)

    @amr Thanks for confirming the fix. The new version of Postman works beautifully in these situations.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Gateway Error, Invalid Envelope from Email Address’ is closed to new replies.