Support » Installing WordPress » garbled install.php in browser

  • Ok, I’ve been at this for about nine hours straight now, didn’t want to come running here without having, at least, tried getting it working on my own.
    But if I don’t get some help with this soon, my laptop is prolly gonna get a free ride out my window – woulnd’t realy want that happening, since it’s now very old…and I might end up hurting someone down on the sidewalk.

    I’ll try to be as precise as I possibly can:

    My host is, danish provider (i think). My database is already installed and they’ve provided me with a username and password, database name and so on (they list WordPress as one of the programs they have tested on their servers, so I should be in the clear there).

    (by the way: MySQL 4.0.18-standard-log running on localhost)

    the (zip) install file, has been unpacked correctly, with the folders and files and so on. Uploaded using SmartFtp to with everything CHMOD’ed as 777.

    the wp-config.php was fed all the info provided by my host (cut’n’paste) and uploaded into the “wp-admin” folder.

    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘edotistic_com_db’); // The name of the database

    (‘DB_USER’, ‘edotistic_com’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘**************’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    ………….[and so on]

    I’m using Opera (but have tried using Firefox and IE with same result), but cannot open the install.php file when in http – I am, however able to force it open via http://ftp…but that’s when it’s getting strange:

    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn’t work for all server setups. The safest way is to manually create the file.”); require_once(‘../wp-config.php’); require_once(‘./upgrade-functions.php’); $guessurl = str_replace(‘/wp-admin/install.php?step=2’, ”, ‘http://’ . $_SERVER[‘HTTP_HOST’] . dirname($_SERVER[‘PHP_SELF’]) ); if (isset($_GET[‘step’])) $step = $_GET[‘step’]; else $step = 0; ?>

    [Word Press Logo]

    hide_errors(); $installed = $wpdb->get_results(“SELECT * FROM $wpdb->users”); if ($installed) die(__(‘

    [Already Installed

    You appear to have already installed WordPress. To reinstall please clear your old database tables first.]

    ‘)); $wpdb->show_errors(); switch($step) { case 0: ?>

    Welcome to WordPress installation. We’re now going to go through a few steps to get you up and running with the latest in personal publishing platforms. You may want to peruse the ReadMe documentation at your leisure.

    It then goes on to list step 1 and 2 (on the same page) with more garbled code.

    Since it’s telling me that Word Press is already installed, I try going on to step 1 […/wp-admin/install.php?step=1] but get a 404…in fact every link gives me a 404].

    As far as I can tell, there’s nothing to indicate that it fails to contact my database – but I’m pretty sure that’s where the problem is.

    The datebase is running just fine, but there are no tables created, neighter by me nor WP.

    If there would a helpful soul that could help me on a bit, I would be extremely thankful.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hey there, lefty. Did you save wp-config-sample.php as wp-config.php?
    The values in your config file look fine, to me. Other than a potential misnomer, I can’t think of anything else that could be wrong. I new to WordPress, too, but I walked through the same bed of coals. Mine ended up being a mis-typed wp-config.


    Are you sure PHP is running? When you see raw code like that, there is something wrong with PHP…

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘garbled install.php in browser’ is closed to new replies.