Support » Installing WordPress » garbled install.php in browser

  • Ok, I’ve been at this for about nine hours straight now, didn’t want to come running here without having, at least, tried getting it working on my own.
    But if I don’t get some help with this soon, my laptop is prolly gonna get a free ride out my window – woulnd’t realy want that happening, since it’s now very old…and I might end up hurting someone down on the sidewalk.

    I’ll try to be as precise as I possibly can:

    My host is, danish provider (i think). My database is already installed and they’ve provided me with a username and password, database name and so on (they list WordPress as one of the programs they have tested on their servers, so I should be in the clear there).

    (by the way: MySQL 4.0.18-standard-log running on localhost)

    the (zip) install file, has been unpacked correctly, with the folders and files and so on. Uploaded using SmartFtp to with everything CHMOD’ed as 777.

    the wp-config.php was fed all the info provided by my host (cut’n’paste) and uploaded into the “wp-admin” folder.

    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘edotistic_com_db’); // The name of the database

    (‘DB_USER’, ‘edotistic_com’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘**************’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    ………….[and so on]

    I’m using Opera (but have tried using Firefox and IE with same result), but cannot open the install.php file when in http – I am, however able to force it open via http://ftp…but that’s when it’s getting strange:

    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn’t work for all server setups. The safest way is to manually create the file.”); require_once(‘../wp-config.php’); require_once(‘./upgrade-functions.php’); $guessurl = str_replace(‘/wp-admin/install.php?step=2’, ”, ‘http://’ . $_SERVER[‘HTTP_HOST’] . dirname($_SERVER[‘PHP_SELF’]) ); if (isset($_GET[‘step’])) $step = $_GET[‘step’]; else $step = 0; ?>

    [Word Press Logo]

    hide_errors(); $installed = $wpdb->get_results(“SELECT * FROM $wpdb->users”); if ($installed) die(__(‘

    [Already Installed

    You appear to have already installed WordPress. To reinstall please clear your old database tables first.]

    ‘)); $wpdb->show_errors(); switch($step) { case 0: ?>

    Welcome to WordPress installation. We’re now going to go through a few steps to get you up and running with the latest in personal publishing platforms. You may want to peruse the ReadMe documentation at your leisure.

    It then goes on to list step 1 and 2 (on the same page) with more garbled code.

    Since it’s telling me that Word Press is already installed, I try going on to step 1 […/wp-admin/install.php?step=1] but get a 404…in fact every link gives me a 404].

    As far as I can tell, there’s nothing to indicate that it fails to contact my database – but I’m pretty sure that’s where the problem is.

    The datebase is running just fine, but there are no tables created, neighter by me nor WP.

    If there would a helpful soul that could help me on a bit, I would be extremely thankful.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Guess this was a double post, huh? When you say “garbled code” what exactly is it? Could you post a (short) example?

    Have you tried dropping the database tables?

    yeah, sorry about the double post – connection hickuped.

    The database claims there are no tables in it:
    [No tables found in database.]

    This is a bit of the code I’m getting:

    Second Step

    Now we’re going to create the database tables and fill them with some default data.
    query(“UPDATE $wpdb->options SET option_value = ‘$weblog_title’ WHERE option_name = ‘blogname'”); $wpdb->query(“UPDATE $wpdb->options SET option_value = ‘$admin_email’ WHERE option_name = ‘admin_email'”); // Now drop in some default links $wpdb->query(“INSERT INTO $wpdb->linkcategories (cat_id, cat_name) VALUES (1, ‘Blogroll’)”); $wpdb->query(“INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES (‘’, ‘Carthik’, 1, ‘’);”); $wpdb->query(“INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES (‘’, ‘Donncha’, 1, ‘’);”); $wpdb->query(“INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES (‘’, ‘Michel’, 1, ‘’);”); $wpdb->query(“INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES (‘’, ‘Ryan’, 1, ‘’);”); $wpdb->query(“INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES (‘’, ‘Matt’, 1, ‘’);”); $wpdb->query(“INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss) VALUES (‘’, ‘Mike’, 1, ‘’);”); $wpdb->query(“INSERT INTO $wpdb->links (link_url, link_name, link_category, link_rss)…….

    It goes on, that’s about a 4th of it, and then:


    Now you can log in with the login “admin” and password “”.

    Note that password carefully! It is a random password that was generated just for you. If you lose it, you will have to delete the tables from the database yourself, and re-install WordPress. So to review:
    Login address

    Were you expecting more steps? Sorry to disappoint. All done! 🙂

    I’m not sure what the setup page is supposed to look like, but I’m guessing that I’m not supposed to see all the steps at once, on the same page.

    Yeah, you’re getting the actual code output. It’s not garbled, it’s just not supposed to display to you – it’s supposed to run. There was a thread around here somewhere a while back about this that included a fix I think. Let me see if I can find a link – might take me a while searching, because I honestly don’t remember what to search for!

    [Edit: Okay this is the thread I remembered. There’s a post by podz that gives two possible reasons for this to be happening. The lady with the original problem never posted back with whether she got it fixed or not.

    Basically, here’s the two possibilities:

    – you do not have PHP on the server. Who are you hosted with ?
    – you have incorrectly uploaded the file. What ftp client do you use?

    Check those out I guess, and let us know….]

    I’m hosted with “” their faq tells me that their using Linux Fedora for their PHP, doesn’t say anything about Apache.

    I have access to phpmyadmin, but I have very limited possibilities; I can’t create a new database (have to use the one that made for me) and messing around with the SQL is a big no-no.

    I can creat tables and so on, but would rather not, as my skills are very limited when it comes to databases i.e. I know what they do and how they work on a basic level…but that’s about it.

    Just for the record; am I supposed to be able to activate WP by regular Http, or do I need to go through the Ftp to make it work?

    And, in phpmyadmin, do I need to kickstart the database in some way, or is it going to come to life when WP tries to activate?

    I’ll try to upload the whole thing again.

    You should be able to install WP by visiting in your browser of choice. Shouldn’t need to do anything besides upload with ftp.

    You might need to check versions etc. with your webhost.

    You have to go through the installation process in your browser, by typing in the address line or with the proper directory name in between if it isn’t in the root. You use the FTP ONLY to upload your files.
    If the data in your config file is correct WP will take care of the rest, i.e. it will create the tables and populate them with the necessary data.

    ah, vkaryl types faster 🙂

    Only sometimes, moshu!

    yeah, ok, just as i figured – that’s pretty much what I’ve been (trying) doing so far.

    But going through the folders via the browser only ends up giving me a 404…however, if I change the http:// to ftp:// I’m able to get in and execute the install.php …..but it gives me the extra raw code and pretty much does nothing.

    But going through the folders via the browser only ends up giving me a 404…

    Which folders? What do you mean by “going through”?
    If 404 – you typing the wrong address.

    hmmm, I just found something out. My host acctualy gives me one more piece of info, it tells me the name (adress) of the mysql server [] …but sadly I’m at quite a loss as to how it can be useful.

    In your config file change this line:
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    to this
    define('DB_HOST', ''); // 99% chance you won't need to change this value

    What you need to put into the browser address bar is: (this is taken from your quasi link above – don’t use the public_html part, that’s part of the path used by ftp etc.)

    You shouldn’t need to access any folders through ftp OR http. All you should need to do is type that line into the addy window, replacing with whatever your site name actually is.

    nope, sorry, still a 404…

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘garbled install.php in browser’ is closed to new replies.