WordPress.org

Forums

Jetpack by WordPress.com
Gap after dialogue box and before comments (8 posts)

  1. jrothra
    Member
    Posted 9 months ago #

    URL: http://www.johnrothra.com/cv/

    There is a large gap between the comment dialogue box and the comments themselves.

    What I've done:
    - Tested with other themes. Twenty Fourteen places the dialogue box after the comments; the other themes have the same gap.
    - Deactivated the "Jetpack Comments" module. The problem went away - no gap.

    How do I remove that giant gap Jetpack is creating?

    https://wordpress.org/plugins/jetpack/

  2. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    Hi,

    Are you still seeing this problem? I'm not seeing a gap (Chrome on Mac): https://cloudup.com/cHdk-uPI7DU

  3. jrothra
    Member
    Posted 9 months ago #

    Brandon,

    Did you click inside the dialogue box? If so, the gap disappears when you do that (even for me). However, it's still there if I don't click in the box.

    Gap visible (did not click in box) - https://drive.google.com/file/d/0B4mnNZ1F-EDsN01LUHJhREtUYU0/edit?usp=sharing

    No gap (clicked in box) - https://drive.google.com/file/d/0B4mnNZ1F-EDscVZBRTZ4RVlwTEU/edit?usp=sharing

  4. jrothra
    Member
    Posted 9 months ago #

    For comparison of a post vs. page, I checked on my latest post (the link in my OP is a page), and the gap is there until I click in the box. There's no comments yet as I just posted it earlier this evening.

    URL: http://www.johnrothra.com/evangelism/celebrating-best-debaucherys-low-standards/

    Gap - https://drive.google.com/file/d/0B4mnNZ1F-EDsMi1ScWJtYXBOSTA/edit?usp=sharing

    No gap - https://drive.google.com/file/d/0B4mnNZ1F-EDsQnB6WV9aZWlfVWc/edit?usp=sharing

    BTW, I've checked IE and Firefox in Windows 7. Gap in Firefox, not in IE.

  5. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    I'm not immediately sure what is causing the issue. There are a number of Javascript errors coming from your site: https://cloudup.com/cMq0YQ04YPI

    The height of the iframe for the comments box is set using Javascript, so my initial thought is those errors are prematurely killing off the script processing and the height change to only include what is needed was further down the line than what failed.

    It looks like you have HTML minification on. Can you disable all minification? It can sometimes create some wonky results and it'd be good to eliminate that as a source.

  6. jrothra
    Member
    Posted 9 months ago #

    The Javascript errors you have in the screenshot, I have no idea what those mean. JWPlayer I use on only one page (http://www.johnrothra.com/evangelism/what-if-a-letter-from-hell/).

    As for minify, I do have W3 Super Cache's minify activated. Here's the settings I used under General Settings and the JS section of the Minify module:

    General - https://drive.google.com/file/d/0B4mnNZ1F-EDsZVJXZ0ZvNndRVjA/edit?usp=sharing
    Minify/JS - https://drive.google.com/file/d/0B4mnNZ1F-EDsb19uYXlDZE1IdWM/edit?usp=sharing

  7. jrothra
    Member
    Posted 9 months ago #

    Also, I do have the plugin WP Deferred Javascripts activated - https://wordpress.org/plugins/wp-deferred-javascripts/

  8. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    Could you deactivate Minify and clear the cache?

    If it still is happening (while leaving Minify off), can you deactivate WP Deferred Javascripts?

Reply

You must log in to post.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic