Support » Plugin: GamiPress - Link » gamipress_specific_id_link_click is triggered but not the id_link

  • Resolved chrisagon

    (@chrisagon)



    Hello,
    I have created a badge with the link requirement “Click a link with the identifier” with ‘manifeste’.
    I have put the gamipress link shortcode in a post with the link_id ‘manifeste’.
    When I inspect the html code generated : the link id is present.
    When I click on this link, the event is triggered but it seems that the link id is not catched, and my badge is not earned. I don’t see the link_id in the log file.I have put the same word ‘manifeste’ as the link id in the requirement and in the shortcode.
    I don’t understand how the link id is catched !

Viewing 1 replies (of 1 total)
  • Plugin Author rubengc

    (@rubengc)

    Hi @chrisagon

    Thanks for your report, your are right about the logs fields, GamiPress has updated their logs some versions ago and GamiPress – Link still using an outdated version of this fields

    I just submitted a fix for this issue and now you will see again those fields

    About award users for click a specific link ID, it works to me, keep in mind that GamiPress – Link offers 2 events:
    Click a link with a specific ID: To award to the user that makes the click
    Get a click on a link with a specific ID: To award to the post author where link is placed

    The second event, checks if user that perform the click and the post author are the same to prevent award himself for click their own links

    Also, you should check if your achievement is correctly setup, keep in mind that achievements has a maximum earnings fields that limits the number of times the achievement can be earned

    Best regards

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.