WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Gamepress: Custom Image Logo no longer working!!! (8 posts)

  1. browndst
    Member
    Posted 2 years ago #

    [Moderator note: Please don't type "LIKE THIS". Three exclamation marks are enough emphasis.]

    http://www.realtalktherapist.com

    I was able to restore the original header.php file but now the custom logo isn't working. I have uploaded the image and it's saved. But it's not showing on the site. Please Help!

    <!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    <head>
    <meta charset="<?php bloginfo( 'charset' ); ?>" />
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
    	<title><?php wp_title(); ?></title>
        <?php if(of_get_option('gamepress_favicon_radio') == 1) : ?>
    	<link rel="shortcut icon" href="<?php echo of_get_option('gamepress_favicon_url'); ?>" type="image/x-icon" />
    	<?php endif; ?>
    	<link rel="profile" href="http://gmpg.org/xfn/11" />
    	<!-- End Stylesheets -->
    	<!--[if lt IE 8]>
    	<link rel="stylesheet" href="css/style_ie.css" type="text/css" media="all"  />
    	<![endif]-->
    	<?php wp_head(); ?>
    </head>
    
    <body <?php body_class(); ?>>
    
    <!-- PAGE -->
    <div id="page">
    	<!-- HEADER -->
    	<header id="header">
    		<div id="header-inner">
    		<div id="logo">
    			<?php if (of_get_option('logo_image')) { ?>
    				<h1><a href="<?php echo home_url(); ?>"><img src="<?php echo of_get_option('logo_image'); ?>" alt="<?php bloginfo( 'name' ); ?>" /></a></h1>
    			<?php }else {?>
    				<h1 id="site-title"><a href="<?php echo esc_url( home_url( '/' ) ); ?>" title="<?php echo esc_attr( get_bloginfo( 'name', 'display' ) ); ?> - <?php bloginfo('description'); ?>" rel="home"><?php bloginfo('name'); ?></a></h1><p><?php bloginfo('description'); ?></p>
    			<?php } ?>
    		</div>
    		<div class="clear"></div>
    		<nav>
    			<?php
    			if(has_nav_menu('primary-menu')){
    				 wp_nav_menu(array(
    					'theme_location' => 'primary-menu',
    					'container' => '',
    					'menu_id' => 'primary-nav',
    					'container_class' => 'main-menu',
    					'menu_class' => 'nav'
    				 ));
    			}else {
    			?>
    				<ul class="nav" id="primary-nav">
    					<?php wp_list_pages('title_li='); ?>
    				</ul>
    			<?php
    			}
    			?>
    			<div id="search">
    				<?php get_search_form(); ?>
    			</div>
    		</nav>
    		</div>
    		<!-- END HEADER-INNER -->
    	</header>
    	<div id="content-wrapper">
    	<div id="content-inner">
  2. alex27
    Member
    Posted 1 year ago #

    You DID NOT restore this file to the original, there is a mistake:

    <?php if (of_get_option('logo_image')) { ?>

    should be

    <?php if (of_get_option('gamepress_logo_image')) : ?>

  3. browndst
    Member
    Posted 1 year ago #

    That worked! thanks so much! Another question: I noticed on the forum others saying they were having trouble with the ad placeholder for this theme. Is that feature working now? Every time I place google adsense ad code inside the editor it creates a bunch of white(light greyish) space around the ad, that doesn't go along with the look of my site. Is there a way to avoid all the extra white space around the ad?

  4. alex27
    Member
    Posted 1 year ago #

    GamePress has no such feature. If you want to display Google Ads you need to integrate them with the theme (put the code in theme files), pasting the code to post editor will not work.

  5. browndst
    Member
    Posted 1 year ago #

    That's what I meant, the theme editor, not not the post! In the heading next to the sites title and tagline, there is a place holder for an ad, what is that for then? see: http://realtalktherapist.com/wp-content/themes/gamepress/screenshot.png

  6. alex27
    Member
    Posted 1 year ago #

    As I said it's not a theme feature, I thought about implementing it, but in the end I didn't do it. So it's time to update the screenshot :) If you go to official demo website though, you'll see that there's no header ad.
    If you add the ad code to header.php it'll probably need some additional CSS styling, so that it lines up with the logo.

  7. browndst
    Member
    Posted 1 year ago #

    okay thanks, I understand.

  8. desikabaddi
    Member
    Posted 1 year ago #

    thanxxxxxxx g my help me........./

Topic Closed

This topic has been closed to new replies.

About this Topic