Support » Plugin: FooGallery - Image Gallery WordPress Plugin » Galley not loading correctly after SSL install

  • Resolved generalnumpty

    (@generalnumpty)


    I use the justified gallery for my images but after I installed my host supplied ssl certificate the images in the gallery all load stacked one image wide and all overlapping. If I refresh the page then the justified gallery looks as it should.
    I have tested on PC, firefox. crome and IE. And also Android phone – chrome and I pad and they all have the same behavour.

Viewing 15 replies - 1 through 15 (of 20 total)
  • Just tested with Masonry gallery and its the same. Also the gallery section of a page gets mixed content warning. I have tested with two different gallery plug ins and they work ok. Maybe that will be my answer but like the Foo gallery and have a lot of them.
    Would be better for me to fix

    Plugin Author bradvin

    (@bradvin)

    hey @generalnumpty

    Please share a link to your site and I can have a look to see what the problem might be.
    When your host changed you over to SSL, did they also update all the media images from http to https? Also, if you have a caching plugin, clear the cache too please

    I have not updated any media images, I am new to WP. All other images that were already there as single images inserted in the normal way do not give mixed content warnings so I can scroll down the page and as soon as I hit the area with the Foo gallery using FireFox I loose the green padlock and it turns to grey with orange triangle.
    I have tested with a gallery plugin by Responsive lightbox and image gallery and that is ok. But I prefer yours and would rather use if I can fix it.
    I do not have a cache plug in. And am using the Mesmerize theme
    In the gallery settings I do not have “Clear HTML Cache” box ticked but I have not yet tied clicking the next settings option which is to “Clear CSS Optimization Cache” (dont know what it means so left it be.
    Thank you for looking in to this for me

    • This reply was modified 2 months, 2 weeks ago by  generalnumpty.
    • This reply was modified 2 months, 2 weeks ago by  generalnumpty.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Hi there @generalnumpty I see you’ve reported this topic twice so far to the Moderators via either the modlook tag or the “Report this topic” link to the side (which just adds the modlook tag).

    Please don’t do that.

    This doesn’t get you help any faster, in fact it only gets you attention from folks whose radar you definitely do not want to be on. 😉

    Sorry But I am new to the forum. I checked out the info and help which said that the only/best way to contact a Mod was to use the “report” and the only thing I could see was report topic. I clicked it and then after a while I noticed it said “report again” and so I assumed that the first one had not gone through so I clicked it again. I did not do it to gain any quicker response. Perhaps that feature needs looking at for idiots like me ?

    I don’t even know what happens next. Am I contacted by a mod to ask what my issue is.
    I did not know I could only edit up to 1 hour, I intended to remove something after a short while but then found that I could not and only a Mod can help.
    For future reference how do I add a modlook tag, I could see nothing referring to that in the help section.
    Thank you and sorry for making newbe mistakes
    I will wait my turn.

    • This reply was modified 2 months, 2 weeks ago by  generalnumpty.
    • This reply was modified 2 months, 2 weeks ago by  generalnumpty.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    I did not know I could only edit up to 1 hour, I intended to remove something after a short while but then found that I could not and only a Mod can help.

    Ah, ok, that is something we can help with.

    When you report a topic, we get a notification to visit the topic, that’s it.

    It is helpful if you add a reply right after (or before) reporting, so that when we visit the topic, we know what you want. 😉

    Otherwise it just looks like you think reporting to a moderator will get you faster help, which happens a lot. 🙁

    So, now that I’m subscribed to this topic, please let me know what you’d like to remove, and I’ll see if it fits in with our content removal policy: https://wordpress.org/support/guidelines/#contacting-the-moderators

    Thank you.
    I added my website which was needed to be looked at and I intended to remove it after a short while once that the plug in maker has seen it. I don’t want to attract any – as you worryingly point out “attention from folks whose radar you definitely do not want to be on” especially as the site is my name.
    If I had known that I can only edit for 1 hour I would of used a different method to get my web address to the plug in maker.
    I could not see anything within the help pages to say that 1 hour edit window was the case.
    Thank you
    I am learning all the time.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    It’s removed now, but do note that it would appear the plugin developer never got a chance to see it or reply.

    I recommend taking the time to present a less personal example of the problem, if you can.

    Please note that we will only remove content if it represents a valid personal safety or security concern, or it violates the guidelines.

    Thank you James – lesson learnt.
    @bradvin let me know if there is another private way I can get the info to you.
    Thank you

    I have cleared the css cache in, foo gallery-settings. And it has made no difference to the ssl issue – it seems the same problem as this https://wordpress.org/support/topic/security-issue-89/
    BUT it does seem to of fixed the issue with the gallery’s not displaying properly

    Plugin Support phillcoxon

    (@phillcoxon)

    Hi @generalnumpty,

    Would you please share a link to a page where we can see the problem? It’s very hard for us to diagnose without directly seeing what’s going on with your site.

    It does sound very much like a caching issue.

    * Please ensure you have cleared both cache buttons in FooGallery -> Settings.
    * Please clear the cache of any other caching plugins you may be using.
    * Please test your site in an incognito or private browser tab to confirm that it is not a local browser issue.

    Hopefully this will resolve what you’re seeing. If not, we’ll be happy to help more when we can see and test the problem directly on your website.

    Thanks!

    Is there a contact I can send my site directly to without having to post it here.
    I dont think the display issue is fixed as i seem to keep having to clear both foogallery caches every once in a while to keep the gallerys displaying properly.
    I do not have a separate cache plug in and I clear both phone and pc cache but not tested in a incognito window.

    Then there is also still the issue with the gallery not being ssl/https (losing green padlock).
    Here is what Firefox console is saying. I have removed my site but it says “http” yet my site is https other plug in gallerys are not giving the mixed content warning.

    Loading mixed (insecure) display content “http://general numpty’s site.co.uk/wp-content/uploads/cache/2018/03/photo-01/1365478954.jpg” on a secure page[Learn More]

    • This reply was modified 2 months, 1 week ago by  generalnumpty.
    Plugin Author bradvin

    (@bradvin)

    you can email me: brad @ fooplugins . com

    Please include a link to your site and also a link to this page so that I can tie the 2 together.

    thanks

    Hi. I did email you but just checking that you received it. I would really like to get this sorted.

    Plugin Support phillcoxon

    (@phillcoxon)

    Hi @generalnumpty,

    Sorry for the delay – I know @bradvin has been away travelling for the last few days so may not have had a chance to review this yet.

    I’ve tagged Brad in to remind him to check his email and respond when he can.

    Please let me know if I can help with anything else. 

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.