WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Gallery showing up in a single column

[Resolved] Gallery showing up in a single column

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Mark Jeldi
    Member

    @mark-jeldi

    Author’s note:

    After troubleshooting via email, this issue appeared to be caused by a TwentyEleven child theme using a non-standard method for calling recent posts on the homepage…likely via a do_shortcode() call or widget (re: Optimizer’s FAQ).

    The solution was to create a custom conditional statement that loads the required scripts and styles on the homepage only (in addition to posts where [nggallery id=x] is detected) so the gallery thumbs display side-by-side and Fancybox functions.

    Cheers,
    Mark.

    Mark

    Apologies, but Ive been sick for a few days.
    I have lost theme mail you sent me. So sorry, but could you please resend it?

    Tx Graham

    Plugin Author Mark Jeldi
    Member

    @mark-jeldi

    Hi Graham,

    No worries. I’ve just resent our earlier email, as requested. Let me know if you require any assistance adding the custom code.

    Hope you’re feeling better.

    Cheers,
    Mark.

    masterkong1
    Member

    @masterkong1

    Mark,
    I have the same issue. Is it possible to send me the steps as well, please? I’m not using Optimizer though.

    W.

    Plugin Author Mark Jeldi
    Member

    @mark-jeldi

    Hi masterkong,

    The conditional statement mentioned above won’t apply if you’re not using Optimizer. It’s a custom function written exclusively for this plugin.

    That said, if you could provide a link to your site, I’d be happy to take a look for you.

    Cheers,
    Mark.

    masterkong1
    Member

    @masterkong1

    Mark. The site is 291.thebccp.org . Appreciate any help. Thanks.

    MK

    Plugin Author Mark Jeldi
    Member

    @mark-jeldi

    Hey MK,

    I’ve just had a look at your site. You don’t appear to be using NextGEN Gallery for your post images, but rather the image uploader/gallery built into WordPress. Also, you seem to have been experimenting with different image sizes and the way they’re inserted, so I’ll just focus on your latest post here to give you an idea…

    If you want your images to display side-by-side, you’ll need to select the default Alignment: “Left” option on the Add Media screen when adding them in your post editor. This will float your images to the left alongside each other until there’s no more room in the post content area. You’ve currently got them set to “center”, which breaks each image onto a new line.

    Additionally, you’ll want smaller image sizes as your current images won’t fit two across (they’re 300px wide). If you select Size: “Thumbnail” on the Insert Media screen instead of “medium” as you have them now, you should be able to fit three images across.

    Hope this helps!

    Cheers,
    Mark.

    masterkong1
    Member

    @masterkong1

    Mark,

    I’m pretty sure we’re using NextGEN because the images are inserted with the shortcode (i.e. [gallery ids="2559,2560,2564"]). It looks like its adding each image as a separate gallery rather than just a single one. The problem also seems to be related to the fact that I can’t add a new gallery in the nextGEN menu on this particular blog. Other blogs in the network work fine.

    MK

    Plugin Author Mark Jeldi
    Member

    @mark-jeldi

    Hi MK,

    The shortcode format [gallery ids="2559,2560,2564"] will insert a WordPress gallery (the one built into the post editor). Also, as it contains three id’s, it will include three images inside the single gallery (as long as they exist).

    To insert a NextGEN gallery, you’d want to use the [nggallery id=x] shortcode.

    I’m not sure why you’re having trouble adding galleries in NextGEN itself, but if you’d like me to take a look, I’d just need a temporary Administrator-level login (my address is on Optimizer’s main page).

    Cheers,
    Mark.

    Mark,
    Good afternoon! Can you take a look as to how I need to fix the single line album issue as well. Here is my site page I am talking about…

    Thanks!
    Mike

    http://www.mmdjsentertainment.com

    Plugin Author Mark Jeldi
    Member

    @mark-jeldi

    Hi Mike,

    I’ve just had a look at your page, and you seem to be using the [album id=x template=extend] shortcode. Is this correct?

    If so, you might like to try the [album id=x template=compact] shortcode, which will line up each thumbnail side-by-side.

    I hope this helps!

    Cheers,
    Mark.

    Mark,
    Thanks! I adjusted it but, the album is still in a single file line. is there a way to create the album like the gallery? Click the wedding photos link page. That is the one currently in question.

    Thanks,
    Mike
    http://www.mmdjsentertainment.com

    Plugin Author Mark Jeldi
    Member

    @mark-jeldi

    Hi Mike,

    Your source code is now calling the correct compact album display, which is great, however, in addition it looks like NextGEN’s stylesheet is not actually loading on that page.

    I suspect this may be because you’re using NextGEN’s new [nggalbum id=x] shortcode to avoid a conflict with your activated copy of Jetpack. Is this correct?

    If so, I’ve just sent you the latest pre-release version of Optimizer Premium (v1.2 due out soon), which includes support for this new shortcode and much more! 🙂

    I hope this helps!

    Cheers,
    Mark.

    Mark,
    I think we are getting close, and thanks for the update! of the 9 galleries in the photo album 6 are in the first row, 1 in the second, and 2 in the 3rd row. Is there something I have to readjust?

    Thanks!
    Mike

    call off the search party… you have take you galleries out, click save and then reinsert them back in the album. Worked like a charm! Thanks Mark!

    Cheers back to you!!!
    Mike

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Gallery showing up in a single column’ is closed to new replies.