Support » Plugin: Custom Simple Rss » Gallery Shortcodes Not Showing As Images

  • Shortcode for “gallery” is remaining a shortcode in the rss feed and not expanding to be the images themselves.

    Default feed shows:

    <a href='https://www.myconfinedspace.com/2019/12/13/spider-hand-stand/spider-hand-stand-2/'><img width="640" height="360" src="https://www.myconfinedspace.com/wp-content/uploads/2019/12/1056158-1000x563.jpg" class="attachment-large size-large" alt="" srcset="https://www.myconfinedspace.com/wp-content/uploads/2019/12/1056158-1000x563.jpg 1000w, https://www.myconfinedspace.com/wp-content/uploads/2019/12/1056158-720x405.jpg 720w, https://www.myconfinedspace.com/wp-content/uploads/2019/12/1056158-200x113.jpg 200w, https://www.myconfinedspace.com/wp-content/uploads/2019/12/1056158-1536x864.jpg 1536w, https://www.myconfinedspace.com/wp-content/uploads/2019/12/1056158-2048x1152.jpg 2048w" sizes="(max-width: 640px) 100vw, 640px" /></a>
    

    Custom Simple RSS feed show:
    [gallery]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author danikoo

    (@danikoo)

    Hi and sorry for the late reply
    in plugin settings please choose under “show post content in feed:”
    the option “show clean html”

    that should do the trick
    let me know if that solved the issue for you

    thanks
    danny

    Ah, that’s one step closer, it looks like the content that’s being generated now from the shortcodes by CSR doesn’t match what the default feed generates and facebook is struggling to recognize images in the feed.

    CSR content:

    <![CDATA[
    <div class="rgg-container" data-rgg-id="1"> <div class="rgg-imagegrid captions-title captions-effect-none " data-rgg-id="1"> <a href="https://www.myconfinedspace.com/2019/12/27/deathstroke-taking-aim/deathstroke-taking-aim-2/" data-rel="rgg" rel="rgg" title="" class="rgg-disabled size-medium rgg-img" data-src="https://www.myconfinedspace.com/wp-content/uploads/2019/12/Iy5Hpni-720x405.jpg" data-ratio="1.7777777777778" data-height="405" data-width="720"> </a> </div> </div>
    ]]>
    

    default content:

    
    <content:encoded><![CDATA[
    <a href='https://www.myconfinedspace.com/2019/12/27/deathstroke-taking-aim/deathstroke-taking-aim-2/'><img width="720" height="405" src="https://www.myconfinedspace.com/wp-content/uploads/2019/12/Iy5Hpni-720x405.jpg" class="attachment-medium size-medium" alt="" srcset="https://www.myconfinedspace.com/wp-content/uploads/2019/12/Iy5Hpni-720x405.jpg 720w, https://www.myconfinedspace.com/wp-content/uploads/2019/12/Iy5Hpni-1000x563.jpg 1000w, https://www.myconfinedspace.com/wp-content/uploads/2019/12/Iy5Hpni-200x113.jpg 200w, https://www.myconfinedspace.com/wp-content/uploads/2019/12/Iy5Hpni-1536x864.jpg 1536w, https://www.myconfinedspace.com/wp-content/uploads/2019/12/Iy5Hpni-2048x1152.jpg 2048w" sizes="(max-width: 720px) 100vw, 720px" /></a>
    
    ]></content:encoded>
    
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.