Support » Fixing WordPress » Gallery settings "type" option not appearing

  • I am trying to create a slideshow following the instructions from the WordPress site:

    However, I do not see the pull down option for “Type” on my end. I only have options for Link To:. Columns, and Random Order. Obviously, this won’t allow me to create a slideshow.

    I’ve done some Google search for advice and logged out, cleared the browser, relaunched, etc., but no help. I’ve also tried doing a new post and saving with a title before proceeding, but this did not help either.

    Now sure how fix this so I can create a slide show on my post.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator Andrew Nevins


    Are you using

    No. I tried to post there and got this automatic reply. I am using WordPress locally for now with MAMP on my iMac before we launch:

    We do not provide support for local installs of software on these support forums. We provide support only for free hosted blogs here.

    Support for your software and any advice you need are provided on the support forums and they are here If you don’t have a username account at, click that link and register one on the top right hand corner of the page that opens, so you can post to the correct support forums for your software.

    Hey CCBB, have you figured out the cause of the “Type” option not showing up? I have the same exact problem and for for the life of me, I cannot seem to determined the cause.

    No, unfortunately, I have not figured it out. I tried working on other themes and different browsers but the same problem exists. My only fix is to create a slide show with iPhoto then upload that to Vimeo and put the link in the post. It’s such a roundabout way to do it, and the slide show must be played rather than going automatically, but it’s the only remedy I seem to have for now since I don’t know coding. Hopefully perhaps a WordPress update will remedy the problem?

    I figured it out just a few moments ago! Apparently the latest WordPress update (3.5.1) disabled the feature. You need to install the free Jetpack plug-in to restore the Type selector.

    I may be mistaken when I say “disable”. I forget whether Jetpack was previously part of, or was installed with previous versions of WordPress. At any rate, installing Jetpack fixed the glitch! You can download Jetpack here:

    Good luck!

    This is great! Thanks for sharing, Wes!

    did that, but still don’t have the Gallery type option in Gallery settings, just Link To, Columns and Random order

    I’m having the same problem. Is it possible the setting is only available for users? I’m not seeing type listed here:

    Can someone confirm that changing a gallery type is built into WordPress 3.5.1?

    Same problem here 🙁

    Same problem with me too.. 🙁
    Am new to WP and do we have any ways to add gallery in a page.
    I was following

    Any help ??

    Same problem. Fresh install of WP on Windows Server 2008 with XAMPP. Installed Jetpack with no effect.



    Forum Moderator

    Did you activate JetPack – it may not work on a localhost site.

    Also, do not use WordPress.COM documentation unless your site is on WordPress.COM.

    It has to do with JetPack. Number of columns wasn’t displaying with me until i disconnected Jetpack

    I had a same problem and solved it. The issue was that I was working on a localhost instead of a real domain.

    Some parts of Jetpack cannot work locally ( ), and also some part’s cannot work if you do not have account connected to your Jetpack installation. So you will probably need to install Jetpack on some real domain and during installation it will ask you to connect to your account.

    Also, go to to Jetpack > Debug (you’ll find small “Debug” link at the bottom of the page) and see if there’s any errors. If you see some – click on it and it will expand and show additional information about the problem.

    Hope this will help someone.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Gallery settings "type" option not appearing’ is closed to new replies.