Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Gallery Settings Not Saving After Update

  • Resolved ispreview

    (@ispreview)


    I’m not sure if this was the WordPress 5.5 update today or the NGG 3.3.10 one, but now whenever I go to ‘NextGen Gallery > Gallery Settings’ and click ‘Save Options’ it throws up this error on /wp-admin/admin.php?page=ngg_display_settings:

    Error thrown
    
    Call to a member function save() on null

    I’m on MySQL 5.7 and PHP 7.4.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Same here, not sure if this is new due to WordPress 5.5.

    Same problem here. Whenever I try to make any changes to the Settings and try to save, it displays the following error –

    Error thrown
    Call to a member function save() on null

    Even if I try to import existing images to the Gallery it displays the same error. I guess the error is related to an upgrade to WordPress 5.5

    I am getting the same today. I haven’t tried to make any changes to Gallery Settings for a few months, so I am not sure if it relates to any recent updates of the plug in or WordPress?.

    When I try to Save Options, I get:
    “TypeError thrown
    Argument 1 passed to iterator_to_array() must implement interface Traversable, null give”

    I have emptied my Chrome cache and re-booted y desktop but no change.

    Any ideas?
    Cheers, Irene

    Sorry I forgot to mention, my above problem is displayed on this page:
    wp-admin/admin.php?page=ngg_other_options

    • This reply was modified 6 months, 3 weeks ago by ifototravel.

    Yes, I am having more problems with the NextGen Pro plugin. It seems that trying to open any of my pre-existing galleries on the page below give me the same TypeError message as well:
    wp-admin/admin.php?page=nggallery-manage-gallery

    It seems that I can create a new Gallery but I cannot access any of my recently created ones prior to today. Aaargh! ;-(

    Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi everyone,

    We are sorry to hear of the encountered issue. We are still inspecting to see why this issue happens for some of the installations only since we weren’t able to replicate it on our testing instances but we had a couple of reports for it until now and those should be enough for our developers to get an idea of a possible fix.

    We’ll keep you updated in case of any findings on this one.

    In case that you want to roll back to the previous version of NextGen Gallery, you can download it from https://downloads.wordpress.org/plugin/nextgen-gallery.3.3.6.zip then go to your site’s “Dashboard -> Plugins”, deactivate and delete the current version of NextGgen Gallery ( this is a safe procedure and you will not lose any galleries or settings ) then install and activate nextgen-gallery.3.3.6.zip

    • This reply was modified 6 months, 3 weeks ago by mihai-imagely.
    Thread Starter ispreview

    (@ispreview)

    Bit of extra feedback. I had to take my main site back to WP5.4.2 due to all the 5.5 bugs, mostly from NextGen. However the originally reported issue above still occurs (as somebody else said, it’s not often we need to save a new setting so this may have been introduced further back). I’ll give NGG 3.3.6 a try and let you know if it goes away.

    Thread Starter ispreview

    (@ispreview)

    Right I put 3.3.6 on under my WP5.5 install and the settings saved without problems, but then I upgraded to 3.3.10 and the aforementioned error returned when trying to save. So it’s definitely been introduced with the 3.3.10 update.

    • This reply was modified 6 months, 3 weeks ago by ispreview.

    save here
    Error thrown
    Call to a member function save() on null

    and all Gallerys lost thumbnail settings.
    before all 100×100, now 100 width and auto high.
    ugly display and sorting

    i back to 3.3.6

    thanks and
    regards
    andrew

    • This reply was modified 6 months, 3 weeks ago by Andrew.
    Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi everyone,

    We have issued a new update for NextGen Gallery that fixes most of the previously reported problems. Kindly update to the latest version and let us know if that fixes the issue.

    Thread Starter ispreview

    (@ispreview)

    Still getting the same error.

    Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @ispreview,

    Thank you very much for your feedback. Just to make sure that we have understood it correctly. Are you referring about the settings not being saved problem or a different issue ( since NGG 3.3.10 introduced a couple of them )

    Try to see here: https://www.hydraitalia.com/galleria/
    If you try to click one of the thumbnails, you can see that the image opens but it is no longer possible to close it or browse …

    Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @stilweb,

    Looks like your case may be different since the theme itself throws a couple of JS errors. To note here that in WP 5.5 they have bumped the jQuery version which caused conflicts with other products as well so you will have to temporarily switch to a theme from the Twenty series to see if this solves the problem.

    If it solves the problem – you will have to reach the theme provider support to ask them for help getting the theme ready for WP 5.5.

    • This reply was modified 6 months, 2 weeks ago by mihai-imagely.

    Error thrown
    Call to a member function save() on null

    – same as before
    – with 3.3.11
    – then on top i have a white bar, one line
    – when i diable plugin the bar is gone
    – i use the Twenty Twenty themes
    thank you.

    • This reply was modified 6 months, 2 weeks ago by Andrew.
Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Gallery Settings Not Saving After Update’ is closed to new replies.